[QGIS-Developer] Running qgis2to3 on windows

DelazJ delazj at gmail.com
Sun May 20 06:14:03 PDT 2018

I'm trying to update a plugin of mine to QGIS3 and follow instructions at
I'm on Windows 10 and am not used to dev env and despite the use of osgeo4w
i encountered some issues.
After some readings here and there, I ran in the osgeo4w shell the
`py3_env` call to update my environment, leading to
PATH contains C:\OSGeo4W64\apps\Python36
PYTHONHOME = C:\OSGeo4W64\apps\Python36
PYTHONPATH = C:\OSGeo4W64\apps\Python36\Lib

Following the wiki, I ran `pip install future` or `pip3 install future`
(I'll realize later that future was already installed) but any call of
pip/pip3 like a simple `pip --help` results in *Fatal error in launcher:
Unable to create process using '"'*
After some search, I found that the call i should do is `python3 -m pip
install future` [1]. Did I miss something or would the guidelines need some
contextualization for beginners like me?

Then running `python3 -m pip install qgis2to3` downloads and installs the
qgis2to3 package in the osgeo4w. But when i run `qgis2to3
/path/to/my/plugin` I simply get a dialog to select the app I'd like to use
to open the file (which happens to be
C:\OSGeo4W64\apps\Python36\lib\site-packages\qgis2to3\__init__.py). No
more. I don't know what to do ...
Sorry if these are noob concerns but I can't move forward so any help would
be more than welcome.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/qgis-developer/attachments/20180520/072d08a5/attachment.html>

More information about the QGIS-Developer mailing list