[QGIS-it-user] QGIS DEV errore qgis_app.dll

Andrea Giudiceandrea andreaerdna a libero.it
Ven 13 Maggio 2022 04:08:37 PDT


Ciao Giulio,
ho installato i pacchetti qgis-dev e qgis aggiornati alle ultime 
versioni disponibili, con i relativi pacchetti da cui dipendono, su 
OSGeo4W senza alcun problema.

In che senso hai "reinstallato completamente"? Hai rimosso tutto il 
contenuto della cartella di installazione di OSGeo4W?

C' stato qualche aggiornamento maggiore di Windows 10 prima che si 
verificasse il problema?

L'errore  molto probabilmente dovuto al fatto che la libreria 
qgis_app.dll dipende da qualche altra libreria che per risulta 
mancante, oppure in una cartella non presente nel path di sistema, 
oppure di una versione non compatibile.

Potresti usare "CFF Explorer" per verificare manualmente se tutte le 
dipendenze di qgis_app.dll sono soddisfatte, oppure potresti usare 
"Dependency Walker" (http://www.dependencywalker.com/ o 
https://github.com/lucasg/Dependencies) con una procedura spiegata 
alcuni anni fa da Jrgen Fischer 
https://github.com/qgis/QGIS/issues/26891#issuecomment-495889169 - 
https://issues.qgis.org/issues/19061#note-16

A presto.

Andrea

Il 13/05/2022 10:13, Giulio Fattori ha scritto:
>
> Buongiorno,
>
>  dall'aggiornamento con OSGeo4W di luned che non riesco ad avviare 
> la master, ottengo sempre questo errore:
>
-------------- parte successiva --------------
Un allegato HTML  stato rimosso...
URL: <http://lists.osgeo.org/pipermail/qgis-it-user/attachments/20220513/86f238df/attachment.htm>


Maggiori informazioni sulla lista QGIS-it-user