[Qgis-user] negative fid-issue with Geopackage

Bernd Vogelgesang bernd.vogelgesang at gmx.de
Tue Jan 12 08:04:44 PST 2021

Thanks for your reply. Just after posting, I had the idea to select the
negative ones and export them seperately, and then had the same idea to
just export without fid, which produced a new fid-field with normal numbers.
I think this would have worked with the hole layer as well, but i can't
test cause i have to quickly resume with the work.

All these fid-issues with geopackages are really nothing you should let
a novice user run into!

Thanx for having a look,


Am 12.01.21 um 16:57 schrieb qgis-user at stripfamily.net:
> what happens if you export->Save As on the layer and uncheck the fid under
> "Select fields to export"?
> For the file I tried this on, it created new fids.
> On 1/12/2021 8:41 AM, Bernd Vogelgesang wrote:
> > Hi,
> >
> > somehow I managed to produce a polygon layer by copying and merging
> > features from other layers, where the fid of those new parts are
> > negative numbers.
> > The features exist, but the attribute entries are not editable, and so
> > isn't the fid itself.
> > Saving as a new layer just reproduces the negative fids and the behaviour.
> > Like always, this issue hits me in the last production phase of a final
> > map, so if anyone has an idea how to transform those non-functional
> > features into normal behaving ones, I would be very grateful.
> >
> > Cheers,
> > Bernd
> > _______________________________________________
> > Qgis-user mailing list
> > Qgis-user at lists.osgeo.org
> > List info: https://lists.osgeo.org/mailman/listinfo/qgis-user
> > Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-user

More information about the Qgis-user mailing list