[SoC] UbuntuGIS Report 10

Jerome Villeneuve Larouche jlarouche at mapgears.com
Tue Jul 29 05:16:29 PDT 2014

I thought about that too and so I tried running "mvn package" in a clean 
Trusty environment with maven 2.2.1 and it worked. I suppose there might 
be something different in the build environment or with the Ubuntu packages.

On 14-07-29 12:08 AM, Ben Caradoc-Davies wrote:
> Jérôme,
> the only thing I can see in your build log that could be a problem is:
> "Setting up maven2 (2.2.1-19) ..."
> Ubuntu maven 2.2.1 has caused so many problems that it has its own 
> section in the user guide:
> http://docs.geotools.org/latest/userguide/build/install/mvn.html
> Can you configure the build to use a better maven? I do not know if 
> this will fix the problem, but it is worth a try.
> Kind regards,
> Ben.
> On 28/07/14 20:02, Jerome Villeneuve Larouche wrote:
>> Hi,
>> This week I continued work on gt-metadata. Thanks to Jody Garnett of
>> GeoTools I was able to get the same source for JSR-275 that is used in
>> the maven build to repackage it. This fix some of the errors I was
>> getting while compiling the build. I'm still having a wildcard error
>> that doesn't happen if I use the same patched pom.xml manually.
>> You can see the build log here:
>> https://launchpadlibrarian.net/180761636/buildlog_ubuntu-trusty-i386.gt-metadata_11.1-2~trusty3_FAILEDTOBUILD.txt.gz 
>> This week I'll be looking into this problem to try to understand why it
>> happens and create a patch for it.

Jérôme Villeneuve Larouche

More information about the SoC mailing list