[fdo-users] FDO Compile error (libxalan-c)

kernel_panic sudoaptgetinstalld00d3 at gmail.com
Mon Oct 5 18:34:13 EDT 2009

Im trying to compile mapguide, but Im having problems compiling FDO

I have followed the procedures from mapguide's and fdo's respective sites,
step by step.

I have tried this in two different virtual machines using virtualbox:
    Host:XP Guest:Kubuntu 9.04
    Host: kubuntu 9.04 Guest: kubuntu 9.04

I have been able to compile apache and, tomcat and php from the aptinstaller
tarball, but the problem starts when I compile FDO, and for what I have
seen, its a fairly common problem:

Building of the Thirdparty/GDAL libraries has been skipped. Environment

variable FDOGDAL points to a previously installed version of GDAL at .
This version of GDAL will be used to build the FDO WMS and GDAL
make[1]: se ingresa al directorio `/opt/OpenSource/Thirdparty'
make[1]: *** No hay ninguna regla para construir el objetivo
`apache/xml-xalan/c/lib/libxalan-c.so.17.0', necesario para `all-am'.
make[1]: se sale del directorio `/opt/OpenSource/Thirdparty'
make: *** [install-recursive] Error 1

That's from: http://lists.osgeo.org/pipermail/fdo-users/2009-January/001367.html

I have triied the following:

- Change the setenvironment.sh to point FDOGDAL to the place where it
is (fdo/gdal i think is the default), as suggested here:

- Install gdal using synaptic (both gdal, libgdal and dev versions),
then change FDOGDAL to point to the location where gdal was installed
by synaptic (usr/include/gdal in my case)

The same error occurs in both cases.

Also, I noticed that on apache/xml-xalan/c/ folder, before I run the
build_thirdparty script, there isnt a lib folder, when the script
fails, the apache/xml-xalan/c/ has a lib folder, with three files, all
three related to libxalanmsg.so, however, there is not any

I read in another forum, related to the compilation of libxalan, that
one needed to change de XALANCROOT path, to solve that same error,
however, I tried export XALANCROOT= to the path where xalan is
(.../xml-xalan/c/) with no success...

This happens with FDO from subversion (fdo 3.3.1), and also if I
download the tarballs from fdo.osgeo download section, versions 3.4.1
RC1, 3.4.0 3.3.2 and 3.3.1)

Any help would be REALLY appreciated!!!

Extra: related posts regarding this error:




-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osgeo.org/pipermail/fdo-users/attachments/20091005/b32a0210/attachment.html

More information about the fdo-users mailing list