[fdo-users] FDO Compile error (libxalan-c)

john spitzer john.spitzer at gmail.com
Mon Oct 5 21:24:13 EDT 2009

I had some issues trying to build FDO from source on Ubuntu. I rescued
these comments from my old internal

The First(FDO) stage requires for gdl, sdf, shp, ogr some fixes in
xml-xalan - looks like something you get for free with visual studio
has to be spelled out in gcc (#include <cstring>) in a number of
places in the code. Also in the gdal sub-build there some issues with
passing environment variables between shell scripts - a well known
trap which can cause grief - I did a hack to get it to work - I do not
remember what the optimal solution is as it was a long time ago.

NB It is essential that gcc/g++ 4.1 be used ortherwise serious other
grief occurs. The default on Ubuntu 9.04 is 4.3 .


On Tue, Oct 6, 2009 at 8:34 AM, kernel_panic
<sudoaptgetinstalld00d3 at gmail.com> wrote:
> Hi
> Im trying to compile mapguide, but Im having problems compiling FDO
> I have followed the procedures from mapguide's and fdo's respective sites,
> step by step.
> I have tried this in two different virtual machines using virtualbox:
>     Host:XP Guest:Kubuntu 9.04
>     Host: kubuntu 9.04 Guest: kubuntu 9.04
> I have been able to compile apache and, tomcat and php from the aptinstaller
> tarball, but the problem starts when I compile FDO, and for what I have
> seen, its a fairly common problem:
> Building of the Thirdparty/GDAL libraries has been skipped. Environment
> variable FDOGDAL points to a previously installed version of GDAL at .
> This version of GDAL will be used to build the FDO WMS and GDAL
> providers.
> make[1]: se ingresa al directorio `/opt/OpenSource/Thirdparty'
> make[1]: *** No hay ninguna regla para construir el objetivo
> `apache/xml-xalan/c/lib/libxalan-c.so.17.0', necesario para `all-am'.
> Alto.
> make[1]: se sale del directorio `/opt/OpenSource/Thirdparty'
> make: *** [install-recursive] Error 1
> That's from:
> http://lists.osgeo.org/pipermail/fdo-users/2009-January/001367.html
> I have triied the following:
> - Change the setenvironment.sh to point FDOGDAL to the place where it is
> (fdo/gdal i think is the default), as suggested here:
>  http://lists.osgeo.org/pipermail/fdo-users/2009-January/001367.html
> - Install gdal using synaptic (both gdal, libgdal and dev versions), then
> change FDOGDAL to point to the location where gdal was installed by synaptic
> (usr/include/gdal in my case)
> The same error occurs in both cases.
> Also, I noticed that on apache/xml-xalan/c/ folder, before I run the
> build_thirdparty script, there isnt a lib folder, when the script fails, the
> apache/xml-xalan/c/ has a lib folder, with three files, all three related to
> libxalanmsg.so, however, there is not any libxalanc...
> I read in another forum, related to the compilation of libxalan, that one
> needed to change de XALANCROOT path, to solve that same error, however, I
> tried export XALANCROOT= to the path where xalan is (.../xml-xalan/c/) with
> no success...
> This happens with FDO from subversion (fdo 3.3.1), and also if I download
> the tarballs from fdo.osgeo download section, versions 3.4.1 RC1, 3.4.0
> 3.3.2 and 3.3.1)
> Any help would be REALLY appreciated!!!
> Extra: related posts regarding this error:
> http://lists.osgeo.org/pipermail/fdo-users/2009-January/001365.html
> http://lists.osgeo.org/pipermail/fdo-users/2009-January/001365.html
> http://lists.osgeo.org/pipermail/fdo-users/attachments/20090626/6d044d8f/attachment.html
> http://lists.osgeo.org/pipermail/fdo-users/attachments/20090630/3e99e394/attachment.html
> _______________________________________________
> fdo-users mailing list
> fdo-users at lists.osgeo.org
> http://lists.osgeo.org/mailman/listinfo/fdo-users

More information about the fdo-users mailing list