[FOSS-GPS] rtrcv base station iput stream issue with ntripclient or tcpclient

Carl Che cche at utilitytelecomaustralia.com.au
Fri May 8 00:25:12 PDT 2015


Has anyone bumped into the following issue using rtcrcv with ntrip caster?

Ntrip Client: always return 401 - unauthorized error.
input base   ntripc rtcm3 C         0       0         0       0 HTTP/1.1 401 Unauthorized

I tried BKG BNC and the account works like a charm.

I then tried str2str to retrieve the ntrip stream and it works properly. I then forwarded that stream (as output) into a local TCP port. I tried netcat and the port is working - spelling out RTCM stream. But when I use rtkrcv to source from (as input) the TCP port, it always return port error.
input base   tcpcli rtcm3 E         0       0         0       0 port error:

I'm using RTCM 3.1 and Ntrip version 1.

Any ideas?

Best Regards,
Lichang (Carl) Che

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/foss-gps/attachments/20150508/4eaf7840/attachment.html>

More information about the FOSS-GPS mailing list