[gdal-dev] Xerces version?

Ben Discoe ben at v...
Wed Sep 11 17:29:04 EDT 2002

> latest Xerces is 2.1.0. Building against it has linking problems.
> should I dig the 1.7.0 version out of the archive part of the
> Xerces site?

I went ahead and tried using 1.7.0. This worked at my other site a couple
months ago, but it didn't work here. The link errors looked like it's
simply not linking with the Xerces library. Indeed, i found that on the
line in the main makefile.vc:

link /dll /debug $(OGR_INCLUDE) $(LIBOBJ) $(ECWLIB) $(OGDILIB) \

I needed to add "$(XERCES_LIB)". This change is probably already in CVS,

Since this worked, i tried going ahead and switching to Xerces 2.1.0. Only
two small changes were needed to get it to build:

<<< #include <dom/DOMString.hpp>
>>> #include <dom/deprecated/DOMString.hpp>

<<< XERCES_LIB = $(XERCES_DIR)/lib/xerces-c_1.lib
>>> XERCES_LIB = $(XERCES_DIR)/lib/xerces-c_2.lib

The resulting library and executables seem to work fine.


More information about the Gdal-dev mailing list