[Gdal-dev] gdaltindex problems on Windows

Chip Hankley Chip.Hankley at rmtinc.com
Thu Apr 7 17:31:44 EDT 2005

Frank, et. al., 

I tried gdaltindex on a couple isolated images, and it seemed to work.
Apparently gdaltindex was choking in a couple of ways:

1) there were some tiles that were completely NODATA (all black edge
tiles, value of "1" I believe).
2) something about the tif format.

I deleted the NODATA tiles from the directory. I then tried to re-run
gdaltindex and received the following errors:

  The instruction at "0x77fcc024" referenced memory at "0x00000000".
The memory could not be "written".
  The instruction at "0x77fcc2c0" referenced memory at "0xd0001301".
The memory could not be "written".

I then ran gdaladdo on the TIFs in the directory, and reran gdaltindex.
It then worked. So, I'm assuming that gdaladdo re-creates or re-formats
the TIF in some way. I created the tiles from a single, larger image
using an AML in ArcInfo. So, I'm assuming that there is some issue with
ArcInfo generated TIFs.

For the record...


> Chip, 
> I would suggest you try some single files and see if you can narrow
> the problem down to just some of your files.  If you can get this
> to happen with a single "not too large" file, then let me know and
> I will see if I can reproduce the problem. 
> This could mean you have a corrupt TIFF file, or it could be
> in the way things are built for FWTools.  I would add I don't
> test gdaltindex.exe. 

Outgoing messages, along with any attachments, are scanned for viruses prior to sending.
NOTICE--This email may contain confidential and privileged information 
for the sole use of the intended recipient.  Any review or distribution
by others is strictly prohibited.  If you are not the intended recipient,
please contact the sender immediately and delete all copies.

More information about the Gdal-dev mailing list