[gdal-dev] "symbol(s) not found for architecture x86_64" when compiling GDAL 2.1.0 on Mac OS X

Michal Migurski mike at stamen.com
Sun Feb 12 11:46:39 PST 2017

Thank you, Even!

This should work for me currently, since I am using this installation of GDAL exclusively for vector work.

If I wanted to compile a version that worked with JPEG and PNG support, am I currently out of luck? I do have the drivers via Homebrew and they have worked for me in the past.


> On Feb 12, 2017, at 11:37 AM, Even Rouault <even.rouault at spatialys.com> wrote:
> On dimanche 12 février 2017 10:52:59 CET Michal Migurski wrote:
> > Hi,
> >
> > I’ve recently switched to a new laptop, and I’m attempting to compile GDAL.
> > I have libpng and jpeg in /urs/local via a fresh installation of Homebrew,
> > and I am attempting to follow instructions for minimal drivers. This has
> > worked without incident for me in the past, but I’m running into a problem
> > I’ve not seen before.
> Michal,
> You need to disable the MRF driver as well since it needs libpng and libjpeg. Unfortunetely I just discovered that the intended --without-mrf option didn't work because of a typo. I fixed this by a simple patch in https://trac.osgeo.org/gdal/ticket/6811 that you can apply.
> Lucian,
> wouldn't it make sense to either be able to build MRF without PNG and/or JPEG support, or if that doesn't make sense automatically disable MRF when they are not available ?
> Even
> --
> Spatialys - Geospatial professional services
> http://www.spatialys.com

michal migurski- contact info and pgp key:
sf/ca            http://mike.teczno.com/contact.html

More information about the gdal-dev mailing list