[gdal-dev] "symbol(s) not found for architecture x86_64" when compiling GDAL 2.1.0 on Mac OS X

Even Rouault even.rouault at spatialys.com
Sun Feb 12 11:57:53 PST 2017

On dimanche 12 février 2017 11:46:39 CET Michal Migurski wrote:
> Thank you, Even!
> This should work for me currently, since I am using this installation of
> GDAL exclusively for vector work.
> If I wanted to compile a version that worked with JPEG and PNG support, am I
> currently out of luck?

No, this is the nominal setup. That should work. Only explicit --without-jpeg / --without-png is 
rarely tested

> I do have the drivers via Homebrew and they have
> worked for me in the past.

If the external libraries are not found, the internal libraries are used (unless you explicity 
disable them with --without-XXX)

Spatialys - Geospatial professional services
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/gdal-dev/attachments/20170212/2799ebc5/attachment.html>

More information about the gdal-dev mailing list