[gdal-dev] "symbol(s) not found for architecture x86_64" when compiling GDAL 2.1.0 on Mac OS X

Michal Migurski mike at stamen.com
Mon Feb 13 14:49:32 PST 2017

> On Feb 12, 2017, at 11:57 AM, Even Rouault <even.rouault at spatialys.com> wrote:
> On dimanche 12 février 2017 11:46:39 CET Michal Migurski wrote:
> > Thank you, Even!
> > 
> > This should work for me currently, since I am using this installation of
> > GDAL exclusively for vector work.

I can confirm that this patch did work for me, with the use of Homebrew-provided PNG and JPEG libraries. I also had to provide Xerces-c to get GML working, and used the same *_PATH env vars.

> > If I wanted to compile a version that worked with JPEG and PNG support, am I
> > currently out of luck?
> No, this is the nominal setup. That should work. Only explicit --without-jpeg / --without-png is rarely tested
> > I do have the drivers via Homebrew and they have
> > worked for me in the past.
> If the external libraries are not found, the internal libraries are used (unless you explicity disable them with --without-XXX)

Hm — this hasn’t exactly been my experience. I have found that without external libraries installed and without CPLUS_INCLUDE_PATH and LIBRARY_PATH defined, the compile process complains about missing *.h header files for JPEG and PNG. I have also tried a bare ./configure without any special env vars, and it halts here:

	checking for json_object_set_serializer in -ljson-c... yes
	using pre-installed libjson-c
	configure: error: could not find json-c/json.h


michal migurski- contact info and pgp key:
sf/ca            http://mike.teczno.com/contact.html

More information about the gdal-dev mailing list