[GeoNode-users] geonode updatelayers exception "non-XML response"

Christian Willmes c.willmes at uni-koeln.de
Thu Nov 5 07:58:48 PST 2015


I can't run the "geonode updatelayers" command anymore, because it 
always aborts with an error like:

 >>Exception: ('GeoServer gave non-XML response for [GET 
<featureType>\n <name>lgm_landmask_hires</name>\n 
<nativeName>lgm_landmask_hires</nativeName>\n <namespace>\n    
<name>geonode</name>\n   [...]

I cant fix the schema in geoserver by reloading the feature type in the 
Layer edit view, but it does not work. It throws really long java stack 
trace in the "publication" tab, one line says:

 >>Caused by: java.io.IOException: Schema 'lgm_landmask_hires' does not 

I also completely deleted another layer, that throwed this same error 
before. But its not really an option to delete all layers to be able to 
run the command again.

I also tried with the --ignore-errors option, but got the same error / 

How can I fix or circumvent this problem?

Thanks and regards,

Christian Willmes	
AG GIS & Fernerkundung      | GIS & RS Group
Geographisches Institut     | Institute of Geography
Universität zu Köln         | University of Cologne
Tel.: +49 (0)221 470 6234

More information about the geonode-users mailing list