[GeoNode-users] geonode updatelayers exception "non-XML response"

Christian Willmes christian.willmes at googlemail.com
Sun Nov 8 23:49:49 PST 2015


any advice on this? How can I fix it and preserve my data, and most 
important the URLs?

I considered reinstalling Geonode, by preserving the GeoServer, but I 
figured, that this may break the URLs, which would be bad, because other 
applications link to the Geonode resources.


Am 05.11.2015 um 16:58 schrieb Christian Willmes:
> Hi,
> I can't run the "geonode updatelayers" command anymore, because it 
> always aborts with an error like:
> >>Exception: ('GeoServer gave non-XML response for [GET 
> http://localhost:8080/geoserver/rest/workspaces/geonode/datastores/datastore/featuretypes/lgm_landmask_hires.xml]: 
> <featureType>\n <name>lgm_landmask_hires</name>\n 
> <nativeName>lgm_landmask_hires</nativeName>\n <namespace>\n    
> <name>geonode</name>\n   [...]
> I cant fix the schema in geoserver by reloading the feature type in 
> the Layer edit view, but it does not work. It throws really long java 
> stack trace in the "publication" tab, one line says:
> >>Caused by: java.io.IOException: Schema 'lgm_landmask_hires' does not 
> exist.
> I also completely deleted another layer, that throwed this same error 
> before. But its not really an option to delete all layers to be able 
> to run the command again.
> I also tried with the --ignore-errors option, but got the same error / 
> abort.
> How can I fix or circumvent this problem?
> Thanks and regards,
> Christian

More information about the geonode-users mailing list