[GeoNode-users] geonode updatelayers exception "non-XML response"

Christian Willmes c.willmes at uni-koeln.de
Tue Nov 10 00:41:51 PST 2015

The "catalina.out" provides some useful information. I did not looked 
there yet, will take some time for it this afternoon, and report back if 
there is still a problem, and what its about. If I still can't fix it, I 
will try to join during the sprint online next week.


Am 09.11.2015 um 15:48 schrieb Jeffrey Johnson:
> Christian,
> Can you join us online next week during the sprint to look into this
> issue? Also, its probably helpful if you paste the stacktrace from
> tomcat.
> Jeff
> On Sun, Nov 8, 2015 at 11:49 PM, Christian Willmes
> <christian.willmes at googlemail.com> wrote:
>> Hi,
>> any advice on this? How can I fix it and preserve my data, and most
>> important the URLs?
>> I considered reinstalling Geonode, by preserving the GeoServer, but I
>> figured, that this may break the URLs, which would be bad, because other
>> applications link to the Geonode resources.
>> Regards,
>> Christian
>> Am 05.11.2015 um 16:58 schrieb Christian Willmes:
>>> Hi,
>>> I can't run the "geonode updatelayers" command anymore, because it always
>>> aborts with an error like:
>>>>> Exception: ('GeoServer gave non-XML response for [GET
>>>>> http://localhost:8080/geoserver/rest/workspaces/geonode/datastores/datastore/featuretypes/lgm_landmask_hires.xml]:
>>>>> <featureType>\n <name>lgm_landmask_hires</name>\n
>>>>> <nativeName>lgm_landmask_hires</nativeName>\n <namespace>\n
>>>>> <name>geonode</name>\n   [...]
>>> I cant fix the schema in geoserver by reloading the feature type in the
>>> Layer edit view, but it does not work. It throws really long java stack
>>> trace in the "publication" tab, one line says:
>>>>> Caused by: java.io.IOException: Schema 'lgm_landmask_hires' does not
>>>>> exist.
>>> I also completely deleted another layer, that throwed this same error
>>> before. But its not really an option to delete all layers to be able to run
>>> the command again.
>>> I also tried with the --ignore-errors option, but got the same error /
>>> abort.
>>> How can I fix or circumvent this problem?
>>> Thanks and regards,
>>> Christian
>> _______________________________________________
>> geonode-users mailing list
>> geonode-users at lists.osgeo.org
>> http://lists.osgeo.org/mailman/listinfo/geonode-users
> _______________________________________________
> geonode-users mailing list
> geonode-users at lists.osgeo.org
> http://lists.osgeo.org/mailman/listinfo/geonode-users

Christian Willmes	
AG GIS & Fernerkundung      | GIS & RS Group
Geographisches Institut     | Institute of Geography
Universität zu Köln         | University of Cologne
Tel.: +49 (0)221 470 6234

More information about the geonode-users mailing list