[GeoNode-users] import SHP

Eugenio Trumpy frippe12573 at hotmail.com
Wed Sep 30 07:05:33 PDT 2015

Hi Paolo,

I did what you suggest.
The shp file has been uploaded correctly in the geoserver,
however I got errors on updatelayers, as follow:

$ python manage.py updatelayers
Stopping process because --ignore-errors was not set and an error was found.
Traceback (most recent call last):
  File "manage.py", line 28, in <module>
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 399, in execute_from_command_line
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 392, in execute
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/base.py", line 242, in run_from_argv
    self.execute(*args, **options.__dict__)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/base.py", line 285, in execute
    output = self.handle(*args, **options)
  File "/dati/geonode/geonode/geoserver/management/commands/updatelayers.py", line 108, in handle
  File "/dati/geonode/geonode/geoserver/helpers.py", line 445, in gs_slurp
    "bbox_y1": Decimal(resource.latlon_bbox[3])
  File "/usr/local/lib/python2.7/dist-packages/django/db/models/manager.py", line 154, in get_or_create
    return self.get_queryset().get_or_create(**kwargs)
  File "/usr/local/lib/python2.7/dist-packages/modeltranslation/manager.py", line 341, in get_or_create
    return super(MultilingualQuerySet, self).get_or_create(**kwargs)
  File "/usr/local/lib/python2.7/dist-packages/django/db/models/query.py", line 383, in get_or_create
    obj.save(force_insert=True, using=self.db)
  File "/usr/local/lib/python2.7/dist-packages/polymorphic/polymorphic_model.py", line 90, in save
    return super(PolymorphicModel, self).save(*args, **kwargs)
  File "/usr/local/lib/python2.7/dist-packages/django/db/models/base.py", line 545, in save
    force_update=force_update, update_fields=update_fields)
  File "/usr/local/lib/python2.7/dist-packages/django/db/models/base.py", line 582, in save_base
    update_fields=update_fields, raw=raw, using=using)
  File "/usr/local/lib/python2.7/dist-packages/django/dispatch/dispatcher.py", line 185, in send
    response = receiver(signal=self, sender=sender, **named)
  File "/dati/geonode/geonode/geoserver/signals.py", line 394, in geoserver_post_save
    create_thumbnail(instance, thumbnail_remote_url, thumbnail_create_url, ogc_client=http_client)
  File "/dati/geonode/geonode/layers/utils.py", line 676, in create_thumbnail
    instance.save_thumbnail(filename, image=image)
  File "/dati/geonode/geonode/base/models.py", line 564, in save_thumbnail
    with open(os.path.join(upload_path, filename), 'wb') as f:
Exception: ('Failed to process reg2001_s_wgs84utm33', IOError(13, 'Permission denied'))

>From the last line, I guess, my problem is on permissions.
Mybey something is missing on my config files....
Where in particular?


> From: pcorti at gmail.com
> Date: Wed, 30 Sep 2015 14:35:45 +0200
> Subject: Re: [GeoNode-users] import SHP
> To: frippe12573 at hotmail.com
> CC: geonode-users at lists.osgeo.org
> On Wed, Sep 30, 2015 at 2:18 PM, Eugenio Trumpy <frippe12573 at hotmail.com> wrote:
> > I just tried with another shp file and everythings went well on online demo,
> > the same error on my installation instead.
> > I'm using the geoserver provided by geonode, that is at 2.7.snapshot version
> > (git revision bca94d09e2e18839814a4b663ba8b0fca2130e47),
> > but I have to highlight my particular config.
> > Actually I have 2 geoserver running in different containers of tomcat6:
> >
> > in the first container runs geoserver1, is at 2.3.2 version, and I'm using
> > it to provide services from my institution for different application
> > in the second container runs geoserver2, this is at version 2.7.snapshot
> > (the version of geoserver provided within the geonode installation.
> >
> > For both geoserver I set the proxypass directive in the apache2 virtualhost
> > as follow:
> >
> >
> > /geoserver http://my_server_name:8080/geoserver
> > /geoserver2 http://my_server_name:8081/geoserver2
> >
> > Of course I modify the geonode's geoserver URL in the local_settings.py and
> > settings.py config file.
> >
> > Was I right?
> >
> What does it happen if you add your shapefile to GeoServer without
> using the GeoNode uploader but using the GeoServer Admin, and then run
> updatelayers on that layer?
> p
> -- 
> Paolo Corti
> Geospatial software developer
> web: http://www.paolocorti.net
> twitter: @capooti
> skype: capooti
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/geonode-users/attachments/20150930/677aa9ef/attachment.html>

More information about the geonode-users mailing list