[GeoNode-users] Database and user "geonode" do not exist after apt-get installation [fixed]

Gi Petrak gkpetrak at gmail.com
Fri Feb 3 09:52:07 PST 2017


I fixed it. It was a permission related issue. I modified my pg_hba.conf
file as following

local   all             postgres                                trust
local   all             all                                         trust
host    all             all            trust
host    all             all             ::1/128                 trust

and the problem solved. (I don't know how secure this is in production...)

Also, to complement the procedure of my first post: As a final step, It is
necessary to restart tomcat7.
This is because geonode DB  was created while Geoserver was up and running.
Thus, Geoserver disabled all the DBMS based stores that I was trying to
upload, since it could not establish a connection.

The error above appears in catalina.out as:
ERROR [geoserver.wms] - Getting feature source: featureType: geonode:
layer-name does not have a properly configured datastore
java.io.IOException: featureType: geonode:natura does not have a properly
configured datastore

A helpful link for this issue:

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/geonode-users/attachments/20170203/2257a6e0/attachment.html>

More information about the geonode-users mailing list