[GeoNode-users] (no subject)

Naresh N naresh919 at gmail.com
Tue May 7 21:43:20 PDT 2019

Dear Amedeo,

Thanks for quick response.
I have changed the GEOSERVER_LOCATION

but I am getting the error in  while uploading layer  "Tried to make a GET
request to http://localhost:8080/geoserver/rest/workspaces/default.xml but
got a 404 status code:'

I am having doubt in following
1. http://localhost:8080/geoserver it is redirecting to http://<our domain
name>:443/geoserver/web/ and showing the following error

*Bad Request*

*Your browser sent a request that this server could not understand.
Reason: You're speaking plain HTTP to an SSL-enabled server port.
Instead use the HTTPS scheme to access this URL, please*

The redirection must be from /etc/tomcat/server.xml of the following
code but it is mentioned scheme as *https* but it is redirecting to

<Connector port="8080" protocol="HTTP/1.1"
    proxyName="<ourDomainName .. for example as* exmaple.com
<http://exmaple.com/> *>"

2. http://<ourdomainname>:8080/geoserver *is redirecting* to http://

* but*  http://<our domain
name>:8080/geoserver/rest/workspaces/default.xml is not redirecting
and as showing 404

Please help me to resolve the issue and understand the above two points



On Tue, May 7, 2019 at 4:05 PM Amedeo Fadini <amefad at gmail.com> wrote:

> Il giorno mar 7 mag 2019 alle ore 11:52 Naresh N <naresh919 at gmail.com> ha
> scritto:
>> Dear Amedeo,
>> Thanks for your reply. I have changed as advised
>> [...]
>> but Now  while uploading the data it is showing the error  ' *Tried to
>> make a GET request to
>> http://<ourdomainname>:8080/geoserver/rest/workspaces/default.xml but got a
>> 404 status code*:'
>> Nope, in this way yo're trying the server is trying to contact geoserver
> at the URL http://<oudomainname>:8080 and is good that you've a 404
> error: port 8080 is not exposed to the external but is redirected by apache
> proxy (yes the geonode conf. seems correct).
> Port 8080 is only available for localhost as the default tomcat port, try
> to set
> to
> http://localhost:8080/geoserver
> Amedeo
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/geonode-users/attachments/20190508/f23c6946/attachment.html>

More information about the geonode-users mailing list