[GeoNode-users] Geonode - uploading works but imports empty layers

Toni Schönbuchner toni.schoenbuchner at csgis.de
Wed May 15 04:23:15 PDT 2019

Dear Muhammad,

unfortunately I currently do not have a 2.8 installation available. Also be aware that the apt
setup might be behind the github branch. Anyways, I´ve tested your SHP with current master
which worked without problems. My guess is either a missconfiguration
or an issue which was resolved after 2.8. You can see a list of merged PR´s here:
https://codepen.io/t-book/full/JVKBpB <https://codepen.io/t-book/full/JVKBpB>

Have you already tried a more verbose geoserver log reporting further checked
apache error.log?

It would help if you could clean those, reupload the file and share the logs in some
pastebin like https://hastebin.com/ <https://hastebin.com/> with me.

Best regards,


> Am 15.05.2019 um 11:37 schrieb Muhammad Nabi Ahmad <mnabiahmad at gmail.com>:
> Dear Toni, Manuela and All
> I am having the same issue. I installed GeoNode 2.8 (using apt-get) on Ubuntu 16.04. The debug option is already true but there is no error while uploading. Once the shape file is uploaded I am also allowed to add metadata as well. Finally, when I view the uploaded layer, I see incorrect bbox (database and GeoServer has incorrect bbox) but even if I pan/zoom to my specific location I cannot see any features. I looked at the database and found the spatial table for layer is empty (but has all the attributes, means table structure was created correctly). I have tried uploading 2 different shape file but both has the same result. 
> Note: Raster layers and Document works fine, its only shape file that is having an issue.  
> Thanks Best regards 
> Muhammad Ahmad
> From: geonode-users <geonode-users-bounces at lists.osgeo.org <mailto:geonode-users-bounces at lists.osgeo.org>> on behalf of Toni Schönbuchner <toni.schoenbuchner at csgis.de <mailto:toni.schoenbuchner at csgis.de>>
> Date: Tuesday, March 20, 2018 at 10:53 AM
> To: <mn.sabatino at gmail.com <mailto:mn.sabatino at gmail.com>>
> Cc: geonode-users <geonode-users at lists.osgeo.org <mailto:geonode-users at lists.osgeo.org>>
> Subject: Re: [GeoNode-users] Geonode - uploading works but imports empty layers
> Dear Manuela,
> how did you install geonode and under which OS?
> Further do you see anything useful in geoserver.log with
> verbose logging set? 
> You can also switch on Django DEBUG in local_settings 
> to get more information.
> Best Regards,
> Toni
> -----------------------------------------------
> -----------------------------------------------
> Kolonnadenstraße 1
> 04109 Leipzig
> -----------------------------------------------
> Mobil    +49/ (0) 176 6680 3198
> Tel                          +49/ (0) 341 24 04 738
> Fax                         +49/ (0) 341 24 04 73
> Web                       http://csgis.de <http://csgis.de/>
> -----------------------------------------------
> Hinweis gemäß § 33 BDSG
> Daten der Verfahrensbeteiligten werden gespeichert. Dieses Dokument ist ausschließlich für den 
> Adressaten bestimmt. Der Inhalt der E-Mail ist vertraulich. Falls Sie diese E-Mail versehentlich 
> erhalten haben, rufen Sie uns unter obiger Rufnummer umgehend an und löschen Sie diese Nachricht 
> von Ihrem Computer. Jegliche Art von Reproduktionen, Verbreitung, Vervielfältigung, Veränderung, 
> Verteilung und/oder Veröffentlichung dieser E-Mail ist verboten.
>> Am 19.03.2018 um 20:00 schrieb geonode-users-request at lists.osgeo.org <mailto:geonode-users-request at lists.osgeo.org>:
>> Message: 1
>> Date: Mon, 19 Mar 2018 12:04:26 +0000
>> From: Manuela Sabatino <mn.sabatino at gmail.com <mailto:mn.sabatino at gmail.com>>
>> To: geonode-users at lists.osgeo.org <mailto:geonode-users at lists.osgeo.org>
>> Subject: [GeoNode-users] Geonode - uploading works but imports empty
>>        layers
>> Message-ID:
>>        <CAG4qXndqFp6-DOHGWsJv-gXRtkADi743Hb7NRAB5NKdw7SQxrw at mail.gmail.com <mailto:CAG4qXndqFp6-DOHGWsJv-gXRtkADi743Hb7NRAB5NKdw7SQxrw at mail.gmail.com>>
>> Content-Type: text/plain; charset="utf-8"
>> Hi,
>> This is Manuela here, I am newbie in Geonode. I just started working on a
>> Geonode project and I am quite new in the field. I worked as a GIS Analysts
>> for almost 5 years and self-taught web development, Python, Django, JS,
>> CSS, HTML etc..
>> At the moment, we built a demo that is not successfully working
>> unfortunately, since I know I do have a lot to learn how to make it work
>> properly I was wondering if you could also help me to fix some issues below
>> listed:
>> - When I click on the geofence test connection in the geoserver it shows an
>> error:
>> ERROR [auth.GeoFenceAuthenticationProvider] - Error in authenticating with
>> GeoFence
>> com.google.common.util.concurrent.UncheckedExecutionException:
>> org.springframework.transaction.CannotCreateTransactionException: Could not
>> open JPA EntityManager for transaction; nested exception is
>> javax.persistence.PersistenceException:
>> - When I try to upload a shp file from the geonode website it works but the
>> layer is empty, with no features in it.
>> I can see the layer stored in the geoserver and the postgres database but
>> there are no records in it.
>> I would really appreciate if you could help in debugging these issues.
>> I am looking forward to hearing from you,
>> *Manuela Sabatino*
>> *T*  +44 7598 060 934
>> *E* mn.sabatino at gmail.com <mailto:mn.sabatino at gmail.com>
> _______________________________________________ geonode-users mailing list geonode-users at lists.osgeo.org <mailto:geonode-users at lists.osgeo.org> https://lists.osgeo.org/mailman/listinfo/geonode-users <https://lists.osgeo.org/mailman/listinfo/geonode-users>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/geonode-users/attachments/20190515/08cd7827/attachment.html>

More information about the geonode-users mailing list