[GeoNode-users] No delete ? No upload ?

Brian Wilson brian at wildsong.biz
Fri May 13 09:07:02 PDT 2022

This should be an easy one for you...

I am using https://github.com/GeoNode/geonode-project.git
It's branch 3.2.x

Before starting I tried out the master.demo.geonode.org, registered,
uploaded a layer, visualized it in a map and then deleted the layer.

I managed to stumble through setting up the Docker geonode project, and to
create a new layer from scratch. I set up on a machine with Internet access
and gave it a domain name and set up .env so it was able to get certs via
Let's Encrypt.

The test machine has 32GB of RAM and 4 cores and 200 or so gigs of space.

I have two major problems with it,

1. There does not appear to be any delete button. There is no DELETE? :-)
Clearly I have done something wrong. :-)  Perhaps I just have not searched
hard enough.

2. Uploads fail. I tested a small shapefile on the demo site and it worked.
On my dockerized set up I tried uploading both the zip and unzipped files.

The error message screams at me that there is a filesystem mount problem
but I don't know which docker container to look at.

Unexpected error! - Unknwon Error Code. Contact the system administrator
for more information regarding this error message. Additional info: [Client
Error: Bad Request
Unexpected exception [Errno 2] No such file or directory:

Happy Friday 13 ~~

Brian Wilson
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/geonode-users/attachments/20220513/76af0a50/attachment.htm>

More information about the geonode-users mailing list