[geos-devel] GeometryPtr or ...
pramsey at cleverelephant.ca
Thu Dec 6 14:46:33 PST 2018
We've got a mishmash in the code base, what should it be?
As a learner arriving at the code base, std::unique_ptr<Geometry> would
have been easier, since then the semantics of the thing are more
immediately transparent then. After working with it for a while, that's
less of an issue because I've internalized the fact that GeometryPtr is a
std::unique_ptr, but still.
The best code styleguide is a consistent code base, so deciding and then
globally changing makes the most sense, IMO.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the geos-devel