[geotk] ISO 19119 service metadata

Robert Csok robert.csok at gmx.de
Tue Sep 22 05:19:29 EDT 2009

Dear Sir or Madam,

Is it currently possible to access the service metadata classes with some version of geotoolkit? The class org.geotoolkit.metadata.iso.identification.DefaultServiceIdentification does not seem to implement any of the subclasses and fields suggested by the ISO 19119 standard. It just extends org.geotoolkit.metadata.iso.identification.AbstractIdentification.
I tried to unmarshall an ISO 19139 compliant XML document containing ISO 19119 service identification information and then again tried to marshall it back to an XML file. The resulting file then lacked the service information previously contained in the original document. I also tempted to create my own instance of org.geotoolkit.xml.MarshallerPool with the classes org.geotoolkit.service.ServiceImpl (from the "pending" branch) and org.geotoolkit.metadata.iso.DefaultMetaData bound to it. It did not help.

Yours faithfully,

Robert Csok

Jetzt kostenlos herunterladen: Internet Explorer 8 und Mozilla Firefox 3 -
sicherer, schneller und einfacher! http://portal.gmx.net/de/go/atbrowser

More information about the Geotoolkit mailing list