[geotk] ISO 19119 service metadata

Cédric Briançon cedric.briancon at geomatys.fr
Tue Sep 22 06:30:50 EDT 2009

Hi Robert,

first, thanks for your interest into the Geotoolkit.org project.

You are putting on the foreground something that has recently been added 
on the Geotoolkit-pending project. This is Guilhem Legal, who worked on 
that part and ported it into pending, and it seems what you are facing 
is a bug.
I have created a Jira task about this problem. You can follow it at: 
It contains your whole email as description. Guilhem will have a look to 
it quickly.

Thanks again for the report of this bug,


Robert Csok a écrit :
> Dear Sir or Madam,
> Is it currently possible to access the service metadata classes with some version of geotoolkit? The class org.geotoolkit.metadata.iso.identification.DefaultServiceIdentification does not seem to implement any of the subclasses and fields suggested by the ISO 19119 standard. It just extends org.geotoolkit.metadata.iso.identification.AbstractIdentification.
> I tried to unmarshall an ISO 19139 compliant XML document containing ISO 19119 service identification information and then again tried to marshall it back to an XML file. The resulting file then lacked the service information previously contained in the original document. I also tempted to create my own instance of org.geotoolkit.xml.MarshallerPool with the classes org.geotoolkit.service.ServiceImpl (from the "pending" branch) and org.geotoolkit.metadata.iso.DefaultMetaData bound to it. It did not help.
> Yours faithfully,
> Robert Csok

More information about the Geotoolkit mailing list