[GRASS5] Re: [GRASSLIST:5321] r3.out.v5d error

John Harrop johnh at sjgeophysics.com
Fri Jan 17 02:28:32 EST 2003


That's the reverse of my problem!  I've been having problems with s.vol.rst 
which I have not solved yet.

You almost certainly should use the g3d routines from the latest CVS 
version of 5.0 source.  (Not to be confused with 5.1)  Quite a few 
important fixes have been done there.  Alfonso Vitti has done a number of 
fixes - including some critical ones to get the g3d read and write 
functions behaving properly.  Some of the loops in the various utilities 
are still causing reversal in N-S or depth.  I've been working with the v5d 
output over the last 6 weeks using 3d geophysical models of electrical 
properties of the sub-surface.  I've modified the loops in s.vol.idw and 
r3.out.v5d to store data in the correct order and thus display in vis5d 
right way up and oriented N-S correctly.  I believe those recent fixes went 
into the CVS.

Looking at the source briefly I note that it might try to use 801 rows in 
vis5d for 800 rows of data.  (Although the test printing the error message 
should not have failed on equality???)  I looked at the new code, so its 
also possible that Alfonso Vitti has fixed the problem (he moved where the 
row/cols are read form region).

Why not try dropping a few more rows to see if the problem goes 
away.  Please let me now the outcome.

John Harrop

At 09:44 PM 16/01/2003 +0100, you wrote:
>Hi all
>I'm interpolating percipitation data with s.vol.rst.
>I tried to export the d3d files (elev, gradient, aspect...)
>to Vis5D with r3.out.v5d and got an error.
>% r3.out.v5d grid3=anasp1555_3 output=anasp1555_3.v5d
>ERROR: Viz5D allows 800 rows, you have 853 rows
>Now I modified the region settings so I have 800 rows.
>But I still get an Error.
>ERROR: Viz5D allows 800 rows, you have 800 rows  (??????)
>Whats wrong with my grass g3d module??? I've installed
>grass5.0. (compiled on my suse 8.0 Box)
>Thanks for help!!

More information about the grass-dev mailing list