[GRASS5] can't start mon under WinGeneric but can under X11, again...

Jeff D. Hamann jeff.hamann at forestinformatics.com
Fri Jan 23 15:06:57 EST 2004

Sorry for the delay and ambigious message, been off on other tasks...

I built the config and got no errors, no window either, but no errors. So
deciding to cut my losses, I went ahead and started X Window and used GRASS
that way...

My error.log file contains the following lines:

GRASS GIS compilation log
Start of compilation: Fri Jan 23 00:38:36 PST 2004
End of compilation: Fri Jan 23 01:21:43 PST 2004
DONE generating GRASS GIS binary code
Which is a good sign.

What I'm really trying to do are the following:

1. Import ASTER data (all the bands).
2. Import a shape file from the area, create a site file from the
centerpoints and perform an image classification
3. Hopefully generate a DEM from the 3N and 3B bands from the ASTER import.

I've run to at least a couple of problems:

1. Importing ASTER images is a pain. I've only been able to import the first
three bands (actually 4 since band three is the same band twice) using
r.in.bin. The other bands won't import even when I use settings from hdf2bin
and use the exact numbers for rows and columns for the other bands. That.. I
just don't get...
2. I've been able to import the shapefile without incident, but don't know
how to project from one speriod to another and from one datum to another.
The Shapefile is in UTM10, NAD27/83, CLARKE66?  and project to ASTER's UTM10
WGS84 WGS84.

I would at least like to be able to import the ASTER files so I tried to
compile (successfully) and use (not so successfully) the gdal libraries.
When I compiled and tried to run r.in.gdal, I got the

GRASS:~ > gdalinfo ast_l1b.hdf
ERROR 4: `ast_l1b.hdf' not recognised as a supported file format.

GDALOpen failed - 4
`ast_l1b.hdf' not recognised as a supported file format.


GRASS:~ > r.in.gdal ast_l1b.hdf output=aster
GBBridgeInitialize() failed to find an suitable GDAL .DLL/.so file.
The following filenames were searched for:
  o libgdal.1.1.so
  o gdal.1.0.so
  o gdal.so.1.0
  o libgdal.so.1

The following locations were searched:
  o /usr/local/grass5/lib
  o System default locations.

System default locations may be influenced by:
LD_LIBRARY_PATH = /usr/local/grass5/lib
ERROR: Unable to initialize GDAL bridge (check libgdal
       installation/LD_LIBRARY_PATH variable).

When I built the gdal libraries, it generated a libgdal.1.1.dll, but didn't
put it in /usr/local/grass5 and the list of filesnames to search in GRASS
doesn't contain a dll extension (I'm guessing it's a documentation thing in
the code though).

I'm thinking this message just covers too much turf to resolve in one
message, so I'm hoping to solve a few of these problems as suggestions are
posted for :

1) gdal importing
2) projecting
3) using generic drivers instead of X Window

Thanks for the patience,

----- Original Message ----- 
From: "Glynn Clements" <glynn.clements at virgin.net>
To: "Jeff D. Hamann" <jeff.hamann at forestinformatics.com>
Cc: <grass5 at grass.itc.it>
Sent: Thursday, January 22, 2004 6:25 PM
Subject: Re: [GRASS5] can't start mon under WinGeneric but can under X11,

> Jeff D. Hamann wrote:
> > Thanks for the help. I tried you're suggestions to no avail.
> >
> > When I built grass503 with the following configuration:
> >
> > $
> >
./configure --without-gd --without-odbc --without-fftw --without-postgres --
> > without-x --without-opengl --enable-w11
> With what result? No errors but no window?
> Did you run "make clean" before/after re-running configure?
> > Could this be a cygwin problem, and if so how could I find out?
> Anything which works on Linux but not on Cygwin is likely to be a
> Cygwin problem in some sense.
> Were there any error messages in error.log? Does driver/XDRIVER.exe
> actually exist?
> -- 
> Glynn Clements <glynn.clements at virgin.net>

More information about the grass-dev mailing list