[GRASS5] Re: [GRASSLIST:10453] gis.m run failure

Michael Barton michael.barton at asu.edu
Tue Feb 21 03:08:05 EST 2006


This will go away tomorrow.

This was my attempt to make it possible to select a map display when you
click on the title bar instead of anywhere else. It did not give the desired
results and I thought I'd erased it before posting the revised version of
this file. Apparently not. It should not cause your version to fail (but it
does). In any case, the small piece of code will be deleted and should not
be a problem after I upload the new version tomorrow.

To select a map display, you will still have to click somewhere on the
window OTHER than the title bar.

Michael Barton, Professor of Anthropology
School of Human Evolution and Social Change
Arizona State University
Tempe, AZ 85287-2402

phone: 480-965-6213
fax: 480-965-7671
www: http://www.public.asu.edu/~cmbarton

> From: Tom Russo <russo at bogodyn.org>
> Date: Mon, 20 Feb 2006 18:25:45 -0700
> To: <grasslist at baylor.edu>
> Subject: [GRASSLIST:10453] gis.m run failure
> I have been a command-line bigot forever, and rarely use the d.m or gis.m
> features of GRASS --- I once tried gis.m and liked what I saw, but don't
> use it routinely, and indeed haven't tried it in a few weeks.  As for
> d.m, my first command on starting GRASS is typically "File->Exit" in d.m.
> After all this talk of revamping GRASS so that the X displays can go away, I
> decided to try out gis.m again lest I fall so far behind the times that
> GRASS becomes unusable for me overnight.  Using grass-6.1 cvs updated last
> night, I get:
>> gis.m
> Error in startup script: bad event type or keysym "ConfigureRequest"
>     while executing
> "bind .mapcan($mon) <ConfigureRequest> {
>                 set wstack %d
>                         puts "stack is $wstack"
>                         puts "mouse click $mon"
>         }"
>     (procedure "MapCanvas::create" line 117)
>     invoked from within
> "MapCanvas::create"
>     (procedure "Gm::startmon" line 11)
>     invoked from within
> "Gm::startmon"
>     (procedure "Gm::create" line 96)
>     invoked from within
> "Gm::create"
>     (procedure "main" line 29)
>     invoked from within
> "main $argc $argv"
>     (file "/usr/local/grass-6.1.cvs/etc/gm/gm.tcl" line 777)
> Any hints on where to look for what's wrong here?  Could this be a tcl/tk
> versioning issue?  (I'm using tcl/tk 8.3, although I do have tcl 8.4 installed
> --- just not set up so that configure finds it, coz once upon a time 8.4 was
> unusable with grass.)
> -- 
> Tom Russo    KM5VY     SAR502  DM64ux         http://www.swcp.com/~russo/
> Tijeras, NM  QRPL#1592 K2#398  SOC#236 AHTB#1
> "And, isn't sanity really just a one-trick pony anyway? I mean all you get is
>  one trick, rational thinking, but when you're good and crazy, oooh, oooh,
>  oooh, the sky is the limit."  --- The Tick

More information about the grass-dev mailing list