[GRASS5] Re: [GRASSLIST:10454] Re: gis.m run failure

Michael Barton michael.barton at asu.edu
Tue Feb 21 03:10:17 EST 2006

I've been working with 8.4.x for quite awhile with no problems on the Mac

Is there any reason now to stay with 8.3? (nviz? Other?)

The current version of TclTk is 8.4.12, with 8.5 nearing release.

Michael Barton, Professor of Anthropology
School of Human Evolution and Social Change
Arizona State University
Tempe, AZ 85287-2402

phone: 480-965-6213
fax: 480-965-7671
www: http://www.public.asu.edu/~cmbarton

> From: Tom Russo <russo at bogodyn.org>
> Date: Mon, 20 Feb 2006 18:39:56 -0700
> To: <grasslist at baylor.edu>
> Subject: [GRASSLIST:10454] Re: gis.m run failure
> On Mon, Feb 20, 2006 at 06:25:45PM -0700, we recorded a bogon-computron
> collision of the <russo at bogodyn.org> flavor, containing:
>> I have been a command-line bigot forever, and rarely use the d.m or gis.m
>> features of GRASS --- I once tried gis.m and liked what I saw, but don't
>> use it routinely, and indeed haven't tried it in a few weeks.  As for
>> d.m, my first command on starting GRASS is typically "File->Exit" in d.m.
>> After all this talk of revamping GRASS so that the X displays can go away, I
>> decided to try out gis.m again lest I fall so far behind the times that
>> GRASS becomes unusable for me overnight.  Using grass-6.1 cvs updated last
>> night, I get:
>>> gis.m
>> Error in startup script: bad event type or keysym "ConfigureRequest"
>>     while executing
>> "bind .mapcan($mon) <ConfigureRequest> {
> [...]
>> Any hints on where to look for what's wrong here?  Could this be a tcl/tk
>> versioning issue?  (I'm using tcl/tk 8.3, although I do have tcl 8.4
>> installed 
>> --- just not set up so that configure finds it, coz once upon a time 8.4 was
>> unusable with grass.)
> Google to the rescue.  Yes, ConfigureRequest is something that is only present
> in tcl 8.4.  
> If this incompatibility with tcl/tk 8.3 is necessary for proper function of
> gis.m, the various install documents should ultimately be updated, and
> perhaps configure should not accept tcl/tk 8.3 anymore.
> Re-adjusting my tcl/tk 8.3 vs. 8.4 install and letting grass use 8.4 fixed
> gis.m.  
> -- 
> Tom Russo    KM5VY     SAR502  DM64ux         http://www.swcp.com/~russo/
> Tijeras, NM  QRPL#1592 K2#398  SOC#236 AHTB#1
> "And, isn't sanity really just a one-trick pony anyway? I mean all you get is
>  one trick, rational thinking, but when you're good and crazy, oooh, oooh,
>  oooh, the sky is the limit."  --- The Tick

More information about the grass-dev mailing list