[GRASS-dev] process terminated/memory access

Martin Wegmann wegmann at biozentrum.uni-wuerzburg.de
Mon Oct 29 09:57:06 EDT 2007


I have several own modules which worked quit good but after the last cvs 
update I receive either:

b7f8a000-b7f8c000 rw-p 00046000 03:03 
1442615    /usr/local/grass-6.3.cvs/lib/libgrass_gis.6.3.cvs.so
b7f8c000-b7f90000 rw-p b7f8c000 00:00 0
b7f90000-b7f93000 r-xp 00000000 03:03 
1442616    /usr/local/grass-6.3.cvs/lib/libgrass_stats.6.3.cvs.so
b7f93000-b7f94000 rw-p 00002000 03:03 
1442616    /usr/local/grass-6.3.cvs/lib/libgrass_stats.6.3.cvs.so
b7f94000-b7f96000 rw-p b7f94000 00:00 0
b7f96000-b7fb2000 r-xp 00000000 03:03 932202     /lib/ld-2.6.1.so
b7fb2000-b7fb4000 rw-p 0001b000 03:03 932202     /lib/ld-2.6.1.so
bf7f5000-bf80b000 rw-p bf7f5000 00:00 0          [stack]
ffffe000-fffff000 r-xp 00000000 00:00 0          [vdso]


D3/5: region item: rows:       477
D3/5: region item: e-w resol:  30
D3/5: region item: n-s resol:  30
D3/5: region item: format:     0
D3/5: region item: compressed: 1
Loading Patches ...  100%
Performing operation distance ...  100%
Writing output ... D1/5: close tmp.NN.NN1.distance compressed
(memory access error)

I saw similar errors from g.copy a couple of weeks/months ago, but they were 
solved with 

make -C general/manage clean
make -C general/manage CFLAGS1='-g'

but that did not work for these modules.

I get this error only when I have a large input but before cvs update I 
executed it successfully with > 100000 cells.

Any idea what changed in the last 8(?) weeks what might cause this error?
Sorry to be so unprecise - but I cannot tell when I updated the last time.

And if yes, how do I have to modify my modules so that they work again?

TIA, Martin

More information about the grass-dev mailing list