[GRASS-dev] GRASS 7 configure fails on Mac

William Kyngesburye woklist at kyngchaos.com
Mon Mar 30 17:50:07 EDT 2009

I looked at configure to see what it's doing for GEOS.  Looks like the  
geos-config option should be the one.  config.log is your friend when  
configure fails.

Is GEOS support really using the C++ API?  geos-config --libs only  
returns the C++ linking info.

Searching the rest of the source, I don't see GEOS used, yet, so there  
should be no problems compiling --without-geos.  Is this yet to come?

On Mar 30, 2009, at 1:42 PM, Martin Landa wrote:

> Hi,
> 2009/3/30 Markus Neteler <neteler at osgeo.org>:
>> On Mon, Mar 30, 2009 at 8:38 PM, Martin Landa  
>> <landa.martin at gmail.com> wrote:
>>> Hi,
>>> 2009/3/30 Michael Barton <michael.barton at asu.edu>:
>>>> I just did an svn update from trunk and tried to configure GRASS  
>>>> 7 prior to
>>>> compiling. I'm using the same configure string that worked  
>>>> successfully 48
>>>> hours ago. But configure failed with an geos-config error  
>>>> (below). Is this a
>>>> bug, or do I need to change my config string to something  
>>>> different?
>>> recently geos supported was added, so you need to install GEOS  
>>> library
>>> or configure with --with-geos=no.
>> Should the default be no (debatable of course..)?
> I was thinking to change it to 'no'. I will do.
> Martin

William Kyngesburye <kyngchaos*at*kyngchaos*dot*com>

"Oh, look, I seem to have fallen down a deep, dark hole.  Now what  
does that remind me of?  Ah, yes - life."

- Marvin

More information about the grass-dev mailing list