[GRASS-dev] Gaining write privileges to usr/local and subdirectories

Paul Schrum paul.schrum at gmail.com
Wed May 24 10:28:37 PDT 2017

Going by
https://grasswiki.osgeo.org/wiki/Compile_and_Install_Ubuntu#GRASS_GIS and
focusing on GRASS GIS 7 trunk:

1. Last week I did

svn co https://svn.osgeo.org/grass/grass/trunk grass7_trunk

On a directory under my ownership.

2.  Today in that same directory I ran
svn up

3. I ran the large statement which begins with

CFLAGS="-O2 -Wall" LDFLAGS="-s" ./configure \

Here is where the problem is.  It seems to go into an infinite loop.*

Also note that when I run it from /usr/local/src/grass7_trunk -- where I
was running it when I started this thread -- it succeeded.  It did not go
into the infinite loop.

* When the process starts, the first few lines read:
./configure: 229: ./configure: Cannot fork
./configure: 300: ./configure: Cannot fork
./configure: 300: ./configure: Cannot fork

There is a lot more I could send but have not, including the last lines
before it restarts at the top of the loop.

Please let me know what more information to five you or what changes I
should make.

- Paul

On Tue, May 23, 2017 at 11:44 AM, Helmut Kudrnovsky <hellik at web.de> wrote:

> Paul Schrum wrote
> > I started off trying to build it in a directory under my home directory
> > using the instructions here
> > <https://grasswiki.osgeo.org/wiki/Compile_and_Install_
> Ubuntu#Dependencies>,
> > but I could not get it to build.  The only part of those instructions
> that
> > I was not following were the path.  So I started using the paths
> indicated
> > in those instructions and then it would build.  That is why my copy of
> the
> > source is where it is.
> >
> > Based on yall's comments, I now think it was something other than the
> path
> > where I was storing the source code, but I have no idea what.
> please post here your steps and error (?)/warning(?) messages of compiling.
> -----
> best regards
> Helmut
> --
> View this message in context: http://osgeo-org.1560.x6.
> nabble.com/Gaining-write-privileges-to-usr-local-and-subdirectories-
> tp5321487p5321504.html
> Sent from the Grass - Dev mailing list archive at Nabble.com.
> _______________________________________________
> grass-dev mailing list
> grass-dev at lists.osgeo.org
> https://lists.osgeo.org/mailman/listinfo/grass-dev
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/grass-dev/attachments/20170524/f543e762/attachment-0001.html>

More information about the grass-dev mailing list