[GRASSLIST:1425] why I always got "LOCATION_NAME not set" when I start Grass5.0 beta 10?

Bei Zhang Bei_Zhang at ndsu.nodak.edu
Mon Feb 5 14:06:39 EST 2001

Hi, all,

I'm new to Grass 5.0 beta 10, here is what I got:

My operating system is Redhat Linux 7.0, I installed Grass5beta10 binary at 
/usr/local/grass, and the tutorial "leics" dataset I downloaded from 
official Grass website was put at /home/username/leics/PERMANENT.

After installation of Grass, I run "grass5" at command line and got 
promption to input GISDBASE, LOCATION_NAME and MAPSET, since it's just a 
try, I pressed "Ctrl+C" to exit the system. Later on, when I typed "grass5 
/home/username/leics/PERMANENT", Grass initiated and automatically loaded 
the tcl/tk GUI, but when I tried to do something like "g.list", I got a 
"LOCATION_NAME not set" error message everytime. But when I typed "set" at 
command line in Grass, I can see that the LOCATION_NAME has been assigned 
"leics", and MAPSET assigned "PERMANENT". So I don't know why I got 
"LOCATION_NAME not set".

Could anybody give me a answer? (Grass 5 manual "startup" section doesn't 
seem to help much)

Thanks in advance,


More information about the grass-user mailing list