[GRASS-user] grass6.2RC3 still problem wtih georectifier

Jarosław Jasiewicz jarekj at amu.edu.pl
Wed Oct 25 11:02:06 EDT 2006

I still have a problem with georectify (tcl gui) as I mentioned before
After fresh installation of grass I created new xy location, imported 
raster, created group, created projected location (EPSG 2173) and have 
tried to use georectify
I choosed location and mapset, group and reference image and tried to 
zoom in (or pan, or zoom out or any othe display operation) and message:

an't read "xy(51)": no such element in array
> can't read "xy(51)": no such element in array
>     while executing
> "if {$xy($gcpnum) != ""} {
>         #draw GCP marks from GCP form
>         for {set gcpnum 1} {$gcpnum < 51 } { incr gcpnum } {
>             if { [$xy($gcpnum) get] != "" } {
> ..."
>     (procedure "GRMap::runprograms" line 93)
>     invoked from within
> "GRMap::runprograms [expr {$mymodified != 0}]"
>     (procedure "GRMap::drawmap" line 39)
>     invoked from within
> "GRMap::drawmap"
>     (procedure "GRMap::display_server" line 13)
>     invoked from within
> "GRMap::display_server"
>     ("after" script)

there is no ground control point or nothig

It was mentioned that error is removed,  so mabye I do something wrong, I don't know....

BTW - it is not a big problem, I can still use i.points and i.rectify for myself, but teatching that (i.point, i.georectify) method is very frustrating, so I can't do it in 18 students group...


More information about the grass-user mailing list