[GRASS-user] Interactive digitizing tool (wxPython) doesn't work and v.out.ogr always crashes under Windows Vista

Frank Bilki fbilki at gmail.com
Wed Jul 22 01:53:24 EDT 2009

Hi All,

I am running GRASS 6.4.0svn under Windows Vista Business Edition
32-bit. I have two related problems:

I used v.in.ogr to import an ESRI Shapefile of the path/row Landsat
scene footprints (polygons) relevant to my project area. Now I want to
adjust the footprints so I can create a clipping polygon for each
scene, which I will then convert to a raster to use as a mask.

I tried to use the interactive digitizing tool in the wxPython UI by
displaying the new vector map, right-clicking it in the map layer
tree, and choosing 'Start editing' from the context menu. It displays
fine, but no matter how often I select my vector map, every tool I use
says, "No vector map selected for editing." I can see the correct map
name right there on the toolbar in the Map Display, so either I'm
doing something fundamentally wrong or there is another problem that
I'm too inexperienced with GRASS to figure out.

Given my inability to edit the vector map in GRASS I tried to export
it back to Shapefile, to edit in Quantum GIS. (The original Shapefile
was not topologically correct.) However, *every* time I try to use
v.out.ogr it crashes outright and I get the Windows message,
"v.out.ogr.exe has stopped working". It doesn't matter if I use the
GUI, enter it into the Cmd window, or use the Windows command prompt,
the result is the same. The command I am attempting is:

v.out.ogr input=WRS50 type=area dsn=/Temp olayer=test

The exact use of the dsn and olayer is not clear to me -- am I about
to create a folder called Temp? If so, where does it go -- inside my
location's folder? I tried creating the Temp folder beforehand but it
still didn't work.

Sorry about all the newbie questions.



More information about the grass-user mailing list