[GRASS-user] digitising area crashed GRASS

Shane Litherland litherland-farm at bigpond.com
Sun Nov 20 09:56:03 EST 2011

Hi Martin,

the wxGUI digitiser. I've been brave lately and given it some
workouts ;-)

alas, tonight, i've had more dramas with it...

Trying to use the 'digitise area' tool for a separate vector has crashed
grass for a second (third, fourth, fifth..) time in a few days. it made
the boundary but not the centroid (I determined that upon re-opening)
and lost topology but seemed to rebuild ok. tried tool again, just the
same way, and it worked with no crash to digitise two more areas, then
crashed on the third.
The next time I opened GRASS to do same process, it crashed on first
area again.

digitising a boundary and manually adding a centroid doesn't seem to
cause me this grief.

Any more sleuthing required at my end?


On Fri, 2011-11-18 at 11:23 +0100, Martin Landa wrote:
> 2011/11/16 Shane Litherland <litherland-farm at bigpond.com>:
> > 6.4.2RC1 ubuntu 10.04.3 wxgui
> >
> > Not as bad as it sounds though...only happened once so far.
> >
> > At first, I thought it was because I may have had the 'no category' or
> > 'don't save to table' settings ( a hangover from whatever I'd just
> > done), and when I used the area tool upon completion of a boundary by
> > right-click, GRASS crashed/closed. Did a restart, the boundary was
> > there, topology had to be rebuilt for the vector layer, easily added the
> > missing centroid. didn't seem to affect other existing parts of vector.
> >
> > have tried area tool again, with several combos of 'add/don't add to
> > table', and 'manual, next, no cats' without any crashes. The area tool
> > even worked with 'no cats' just made a centroid with no cat.
> >
> > so dunno what happened. if it does again, will try and note more detail.
> are you speaking about v.digit of wxGUI digitizer?
> Martin

More information about the grass-user mailing list