[GRASS-user] problem with r.li.mps

Hamish hamish_b at yahoo.com
Mon Sep 19 01:20:22 EDT 2011

ahmadou dicko wrote:
> I  tried to reproduce the r.li exemple from the GRASS book 
> and have a problem with  r.li.mps, i tried with the 6.4.2svn
> version and i upgrade to 6.5svn but i still have the same 
> issue. 
> (i skip the part of the code where forest1996 is build).

could you describe the method? is it just an extraction of
category 2 from landcover_1m?

[If it is ok with Markus & Helena perhaps we could add it as the
example on the r.li.mps help page]

> I don't know if this matter but i use kubuntu natty. And
> ask me for more info if necessary.
> so forest1996 is my raster map of forest category (only).
> r.li.mps --overwrite map=forest1996 conf=movwindow7 output=forest_p_mps7
>  *** glibc detected *** r.li.mps: double free or corruption
> (fasttop): 0x0000000001e17bf0 ***
> r.li.mps(calculate+0x58e)[0x4017fe]
> r.li.mps(meanPatchSize+0x148)[0x402cc8]
> /usr/local/grass-6.5.svn/lib/libgrass_rli.so(worker+0x2fa)
> 1314471                    /lib/x86_64-linux-gnu/libm-
> 2.13.so*** glibc detected *** r.li.mps: free(): invalid next
> size (fast): 0x0000000001e181e0 ***


More information about the grass-user mailing list