Stephen Sefick sas0025 at auburn.edu
Tue Feb 14 07:48:51 EST 2012

Try starting up GRASS and look where the database is in the GUI.  Maybe 
that will work?  I can't test it because I am running Ubuntu.


On 02/14/2012 06:00 AM, Johannes Radinger wrote:
> Hi,
> Roger Bivand recommend this list to be more suitable for my sort
> of question the R-sig-geo.
> I'd like to use R outside a running GRASS session.
> With the R package 'spgrass6' I can initiate a GRASS session (using
> the function initGRASS). Therefore I need the path of the GISBASE.
> I am working on Max OSX and my GRASS 6.5 has been selfcompiled and installed via the command console (sudo make install). The programm is
> now here: "/Applications/GRASS-6.5.app"
> What is now the correct path to my GISBASE or how can I find this out?
> Does anyone have experience with that? This refers to that topic:
> http://grass.osgeo.org/wiki/Working_with_GRASS_without_starting_it_explicitly#GRASS_databases
> although it is still not clear how to find out where my GISBASE is on my Mac?
> Any suggestions?
> Best regards,
> Johannes
> On Tue, 14 Feb 2012, Johannes Radinger wrote:
>> Hello,
>> I want to use spgrass6 in an R session outside GRASS on Mac OSX.
>> Therefore I want to use initGRASS to set some needed environmental
>> variables etc. initGRASS() needs gisBase as one parameter which is the
>> direcotry path to the GRASS binaries. What is the standard path on Mac
>> OS X? My GRASS.app is in / /Applications/GRASS-6.5.app...
>> so I tried following two approaches so far without success:
> Please ask on statgrass or grass-users with reference to:
> http://grass.osgeo.org/wiki/Working_with_GRASS_without_starting_it_explicitly
> saying how you installed OSX GRASS. The views that OSX and R or Python or
> other scripting languages have of the file system may well differ a good
> deal.
> Roger
>>> initGRASS("/Applications/GRASS-6.5", home=tempdir())
>> Fehler in initGRASS("/Applications/GRASS-6.5", home = tempdir()) :
>>   /Applications/GRASS-6.5 not found
>>> initGRASS("/Applications/GRASS-6.5.app", home=tempdir())
>> Fehler in system(paste("g.version", get("addEXE", envir = .GRASS_CACHE),  :
>>   Fehler bei der Ausf"uhrung des Kommandos
>> I don't know what is causing the problem in the second approach?
>> Does anyone know how to use initGRASS on Mac OS X in an R session outside GRASS correctly?
>> Best regards,
>> Johannes
>> --
>> _______________________________________________
>> R-sig-Geo mailing list
>> R-sig-Geo at r-project.org
>> https://stat.ethz.ch/mailman/listinfo/r-sig-geo

Stephen Sefick
Auburn University
Biological Sciences
331 Funchess Hall
Auburn, Alabama
sas0025 at auburn.edu

Let's not spend our time and resources thinking about things that are so little or so large that all they really do for us is puff us up and make us feel like gods.  We are mammals, and have not exhausted the annoying little problems of being mammals.

                                 -K. Mullis

"A big computer, a complex algorithm and a long time does not equal science."

                               -Robert Gentleman

More information about the grass-user mailing list