[GRASS-user] R: R: R: Grass 7.4.0 install error

Aldo CLERICI aldo.clerici at unipr.it
Fri Feb 16 17:00:27 PST 2018

following your suggestions :
I deleted the OSGeo4W installation (and all the previous versions of GRASS)
I started with a new OSGeo4W installation of GDAL (GDAL 2.2.3) with no errors
I tried to install GRASS7.4 in OSGeo4W but with no success. 

The search for sqlite3* gave:   sqlite3.dll in C:\Windows\System32

The installation of GRASS7.4.0 32 bit works fine.

As I wrote in my previous message I was able to install GRASS7.4.0 64 bit on another PC with Windows 7 OS so I don't have any problems in using GRASS7.4. If the problem on Windows 10, as it seems, is only mine, it is not very urgent and I will try to solve it calmly with the help of some Windows expert from my Department. You certainly have more general and more urgent problems to solve for the GRASS Community.
Many thanks to you and everybody at the GRASS Development Team.
Aldo Clerici

-----Messaggio originale-----
Da: Helmut Kudrnovsky [mailto:hellik at web.de] 
Inviato: venerdì 9 febbraio 2018 13:02
A: Aldo CLERICI <aldo.clerici at unipr.it>; grass-user at lists.osgeo.org
Oggetto: Aw: R: [GRASS-user] R: Grass 7.4.0 install error

[please keep it on the ML]
>Gesendet: Freitag, 09. Februar 2018 um 12:32 Uhr
>Von: "Aldo CLERICI"
>Sorry, here the translation:
>g.list.exe - Impossible to find the entry point Impossible to find the 
>entry point sqlite3_column-origin_name of the procedure in the dynamic 
>link library C:\OSGE04~1\bin\gdal202.dll.

it looks like there is another sqlite3 in your %PATH%.

see e.g.

which interferes with the OSGeo4W sqlite3.

as already yesterday mentioned on the ML:

could you type in a windows console:

where "$path:sqlite3*"

or search in C:\Windows in the explorer for sqlite3*

and report the results here on the ML

kind regards

-----Messaggio originale-----
Da: grass-user [mailto:grass-user-bounces at lists.osgeo.org] Per conto di Helmut Kudrnovsky
Inviato: giovedì 8 febbraio 2018 18:29
A: grass-user at lists.osgeo.org
Oggetto: Re: [GRASS-user] R: Grass 7.4.0 install error

Aldo Clerici wrote
> I tried to install 7.4.0 via OSGeo4W on my Windows 10 PC but without 
> success (see error in att.1-2) I installed 7.4.0, 7.2.2 via 
> Stand-alone installer and 7.4.0 via OSGeoW4 on an old PC with Windows
> 7 and all work fine.
> Surely something strange in my Windows 10 OS, but it's strange I was 
> able to install 7.2.0 and 7.0.x not long ago.
> I'll try to discover the problem with some Windows expert at my 
> Department.
> Many thanks to everybody.
> Aldo Clerici

could you translate the error messages?! it's italian....

AFAIU it's not a windows 10 problem, but a missing dependency problem.

could you try following steps in OSGeo4W:

- delete your OSGeo4W installation
- start with a new fresh OSGeo4W installation by first only a basic installation, i.e. GDAL, proj4,
- open the OSGeo4W shell and type: gdalinfo --version to see if GDAL crashes
- then install GRASS7.4 in OSGeo4W
- try to open GRASS7.4 and see if it crashes
- then install QGIS and see if it crashes

and report back the results of the several steps.

the qgis-common-error seems not to be a GRASS error.

best regards
Sent from: http://osgeo-org.1560.x6.nabble.com/Grass-Users-f3884509.html
grass-user mailing list
grass-user at lists.osgeo.org

More information about the grass-user mailing list