[GRASS-user] Problems on MacOS Catalina Installation via Homebrew "Cannot find proj.db"

Vaclav Petras wenzeslaus at gmail.com
Mon Mar 30 18:46:57 PDT 2020

Dear Veronika,

Thank you for awesome analysis. I don't have an answer, but I'm struggling
with the same and I thought it might be a good idea to connect the related

[GRASS-dev] Automatic/CI compilation on macOS

[Bug] Update build GRASS as macOS application #457 (linked comment and


On Fri, Mar 27, 2020 at 12:49 PM Veronika Grupp <vroni.grupp at web.de> wrote:

> Dear GRASS GIS users,
> After installing GRASS GIS via Homebrew I encountered a problem when I
> tried to create a new location and set the projection. (I also posted this
> question on Stackoverflow:
> https://stackoverflow.com/questions/60871421/grass-gis-installed-with-homebrew-create-new-location-cannot-find-proj-db-err
> )
> Maybe someone of you has encountered the same problem or has any idea what
> might be the issue..
> I work on MacOS Catalina and installed the latest stable release of GRASS
> GIS (7.8.2) with Homebrew via the osgeo/osgeo4mac tap using the commands brew
> tap osgeo/osgeo4mac and brew install osgeo-grass (as described on the
> GRASS website
> https://grasswiki.osgeo.org/wiki/Compiling_on_MacOSX_using_homebrew).
> To get the GUI working also pip3 install wxpython was necessary. I could
> start GRASS with grass78 on the commandline. When I tried to create a new
> location and to set the projection/crs
>    1. I could not specify an EPSG code
>    2. browsing a georeferenced file to use its projection threw the
>    error: "proj_get_authorities_from_database: Cannot find proj.db"
> and creation of location was cancelled.
> Regarding 1. EPSG codes: the newest proj version does not provide a file
> with epsg codes, seems like this was already an issue in GRASS 7.6 combined
> with proj 6.x (https://trac.osgeo.org/grass/ticket/3863) but still
> couldn't find a way to get it working e.g. with another epsg file copied
> into the directory.
> Regarding 2. I tried several things that didn't work:
> I installed proj 5 (with brew install osgeo-proj at 5) and also proj 6 (with
> a bottle from https://bottle.download.osgeo.org/?C=N&O=A) but it throws
> errors at the same point saying that some library (refering proj) was not
> loaded and image was not found.
> I tried to set the environment variable PROJ_LIB in .zshenv to the
> respective path where proj.db is located (for version 6 and 7
> respectively), still it threw the same error(s).
> Do I need to set any other environment variables or might it be something
> related to GDAL?
> Thank you very much.
> Veronika
> _______________________________________________
> grass-user mailing list
> grass-user at lists.osgeo.org
> https://lists.osgeo.org/mailman/listinfo/grass-user
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/grass-user/attachments/20200330/3ce5a745/attachment.html>

More information about the grass-user mailing list