[Mapbender-users] Mapbender 2.5 and digitizing: featureTypeArray is not defined, map.php (line 2702)

vollbotz volker.emmel at lwk-rlp.de
Tue Oct 28 11:06:40 EDT 2008

hi list,

i have the same problem with the digitizing modul...
(i use the same infrastructure like matti silvennoinen )

after digitizing - and selecting the wfs  >  i could not save
- i got no mapbender error message / i got no ok message...

> in the mapbender_error_log i got the entries:
Notice: gui id not set
Notice: mb_validateSession.php: gui_id not set in script
Notice: mb_validateSession.php: e_id not set in script

and - in the firefox error-console it got the same like Matti !!!
featureTypeArray is not defined ...
but on line (line 2879)
hmm - the map.php has got only 145 lines....

does anyone know what i (we)  have to do ??

thanks !


Matti Silvennoinen wrote:
> Hi All,
> I am trying to digitize objects (points and polygons) with MapBender 2.5 
> through Geoserver 1.5.2 (WFS-T) to postgis database but I am getting this 
> error when completed attribute form and clicked SAVE button:
> Firefox
> featureTypeArray is not defined
> var featureNS=featureTypeArray[0];var str='<wfs:Transaction 
> version="1.0.0" serv...
> map.php (line 2702)
> I got digitizing working with version 2.4.4 but now I try to use version 
> 2.5. Even the example gui_digitize don't work (same error when trying to 
> digitize "MyPoints"). The same example in version 2.4.4 works well. Do you 
> get the same error with MB2.5 gui_digitize example and what is the 
> solution?
> Regards,
> Matti Silvennoinen
> _______________________________________________
> Mapbender_users mailing list
> Mapbender_users at lists.osgeo.org
> http://lists.osgeo.org/mailman/listinfo/mapbender_users

View this message in context: http://www.nabble.com/Mapbender-2.5-and-digitizing%3A-featureTypeArray-is-not-defined%2C-map.php-%28line-2702%29-tp20032774p20209007.html
Sent from the mapbender-users mailing list archive at Nabble.com.

More information about the Mapbender_users mailing list