[Mapbender-users] Installing Mapbender from SVN-trunk, some general questions

Christoph Baudson (Wheregroup) christoph.baudson at wheregroup.com
Wed Jan 20 05:30:07 EST 2010

Marc Jansen schrieb:
> Hi List,
> I experienced some problems when trying to install Mapbender from 
> trunk. Hopefully someone can point me in the right direction.
> What I did:
>   1. Checked out the source from SVN
>   2. Exported the directories below (those were listed in
>      'Install.txt') to a seperate directory
>          * conf
>          * core
>          * documents
>          * http
>          * lib
>          * license
>          * log
>          * owsproxy
>          * resource
>   3. ran the great install.sh to populate the DB (PG 8.4 with PostGIS
>      1.4.1 on Ubuntu 09.10, that is)
>   4. configured Apache to have an appropriate alias
>   5. edited mapbender.conf to fit my setting
> First of all I would guess that the folder 'tools' should be exported 
> as well, right? (for the I18n-stuff) If so, the file 'Install.txt', 
> should be updated IMHO.
> Accessing the virtual directory worked as expected, I see the greeting 
> screen with login mask, I can login as root and the list of 
> applications is fine.
> I noticed errors (?) with some of the GUIs though:
>    * GUI 'gui': Firebug says: "setBBOX: no bounding box found.", the
>      log-file dito:
>          o "Warning: the sessionVariable: mb_myBBOX is read but it's
>            not set!'"
>          o "Warning: the sessionVariable: mb_myPOI is read but it's not
>            set!'"
>          o "Warning: the sessionVariable: mb_myBBOXEpsg is read but
>            it's not set!'"
>          o same with "mb_myBBOXEpsg", "mb_myBBOXEpsg_transform"
>    * the GUI 'gui' itself looks ok to me, and seems to be working
>      correctly. Why the warnings? Should I bother?

Don't worry about these. I guess we have no strict rules when a message 
is considered exception warning or notice. The first one should be a 
warning, not an error, the others should be notices.

>    * GUI 'gui1': Throws a JavaScript erro in instanciation and does not
>      finish loading: Firebug complains "$.widget is not a function
>      (3175 out of range 997)", the logfile:
>          o Notices more or less the same as above, but...
>          o "ERROR: Javascript not found: mod_addCSW.php"

I assume, that jQuery UI is not included in the application. But I'm a 
little confused, because I installed Mapbender yesterday and gui1 is 
working fine.

The file mod_addCSW.php is still not in trunk. It got lost during 
merging from GSoC 09. I guess I will have to ask Astrid who merged the 

>    * GUI 'gui2': loads more or less, but no maps are visible, only the
>      other HTML elements, Firbug throws an error:
>      "$(savewmcHtml).dialog is not a function", and the logfile only
>      has some notices, no errors

The same as gui1, missing jq_ui elements. I consider gui2 deprecated, 
but there are other opinions.

>    * GUI 'gui_digitize': loads fine and is usable (I did not test every
>      aspect, but it seems ok), no errors just notices in the logfile.
> Is there one step in installing Mapbender that I missed?
> Are the warnings/errors I see (at least partly) caused by the missing 
> 'tools' folder?

Tools folder is not in the http folder because there are some scripts in 
there that can be exploited, like mapbender_setup.php (that's 
information you don't want to share).

> TIA and regards,
> Marc

Any questions, please contact us



Aufwind durch Wissen!

Qualifizierte OpenSource-Schulungen
bei der www.foss-academy.eu



W h e r e G r o u p GmbH & Co. KG

Siemensstraße 8
53121 Bonn

Christoph Baudson

Fon: +49 (0)228 / 90 90 38 - 15
Fax: +49 (0)228 / 90 90 38 - 11
christoph.baudson at wheregroup.com
Amtsgericht Bonn, HRA 6788

WhereGroup Verwaltungs GmbH
vertreten durch:
Olaf Knopp, Peter Stamm

More information about the Mapbender_users mailing list