[Mapbender-users] Installing Mapbender from SVN-trunk, some general questions

Marc Jansen jansen at terrestris.de
Wed Jan 20 06:10:36 EST 2010

Hi Christoph,

thanks for the quick response. Find some comments inline in your answer.

Christoph Baudson (Wheregroup) wrote:
> Marc Jansen schrieb:
>> Hi List,
>> I experienced some problems when trying to install Mapbender from 
>> trunk. Hopefully someone can point me in the right direction.
>> What I did:
>>   1. Checked out the source from SVN
>>   2. Exported the directories below (those were listed in
>>      'Install.txt') to a seperate directory
>>          * conf
>>          * core
>>          * documents
>>          * http
>>          * lib
>>          * license
>>          * log
>>          * owsproxy
>>          * resource
>>   3. ran the great install.sh to populate the DB (PG 8.4 with PostGIS
>>      1.4.1 on Ubuntu 09.10, that is)
>>   4. configured Apache to have an appropriate alias
>>   5. edited mapbender.conf to fit my setting
>> First of all I would guess that the folder 'tools' should be exported 
>> as well, right? (for the I18n-stuff) If so, the file 'Install.txt', 
>> should be updated IMHO.
>> Accessing the virtual directory worked as expected, I see the 
>> greeting screen with login mask, I can login as root and the list of 
>> applications is fine.
>> I noticed errors (?) with some of the GUIs though:
>>    * GUI 'gui': Firebug says: "setBBOX: no bounding box found.", the
>>      log-file dito:
>>          o "Warning: the sessionVariable: mb_myBBOX is read but it's
>>            not set!'"
>>          o "Warning: the sessionVariable: mb_myPOI is read but it's not
>>            set!'"
>>          o "Warning: the sessionVariable: mb_myBBOXEpsg is read but
>>            it's not set!'"
>>          o same with "mb_myBBOXEpsg", "mb_myBBOXEpsg_transform"
>>    * the GUI 'gui' itself looks ok to me, and seems to be working
>>      correctly. Why the warnings? Should I bother?
> Don't worry about these. I guess we have no strict rules when a 
> message is considered exception warning or notice. The first one 
> should be a warning, not an error, the others should be notices.


>>    * GUI 'gui1': Throws a JavaScript erro in instanciation and does not
>>      finish loading: Firebug complains "$.widget is not a function
>>      (3175 out of range 997)", the logfile:
>>          o Notices more or less the same as above, but...
>>          o "ERROR: Javascript not found: mod_addCSW.php"
> I assume, that jQuery UI is not included in the application. But I'm a 
> little confused, because I installed Mapbender yesterday and gui1 is 
> working fine.

which other information would you like to have in order to narrow down 
the problem? Did you install from a clean trunk or from some local copy 
of Mapbender? Did I miss any important steps in installing Mapbender?

> The file mod_addCSW.php is still not in trunk. It got lost during 
> merging from GSoC 09. I guess I will have to ask Astrid who merged the 
> files.

OK, thanks.

>>    * GUI 'gui2': loads more or less, but no maps are visible, only the
>>      other HTML elements, Firbug throws an error:
>>      "$(savewmcHtml).dialog is not a function", and the logfile only
>>      has some notices, no errors
> The same as gui1, missing jq_ui elements. I consider gui2 deprecated, 
> but there are other opinions.

so that's missing files in trunk, right?

>>    * GUI 'gui_digitize': loads fine and is usable (I did not test every
>>      aspect, but it seems ok), no errors just notices in the logfile.
>> Is there one step in installing Mapbender that I missed?
>> Are the warnings/errors I see (at least partly) caused by the missing 
>> 'tools' folder?
> Tools folder is not in the http folder because there are some scripts 
> in there that can be exploited, like mapbender_setup.php (that's 
> information you don't want to share).

I don't want the folder to be moved to the http-folder. I would simply 
suggest listing the fiolder in the file Install.txt, so one does export 
the folder when installing from trunk. Correct me if I am wrong, but the 
folder itself is needed in order to run setup.sh, isn't it?

Bye and thanks,

>> TIA and regards,
>> Marc
> Any questions, please contact us
> Christoph

More information about the Mapbender_users mailing list