[Mapbender-users] Load WMS Error

Thomas Baschetti info at thomas-baschetti.de
Thu Jul 26 01:14:18 PDT 2012


glad to hear your problem seems to be solved.

The columns you mentioned are added in some update-sqls (e.g. update_2.7rc1_to_2.7rc2_pgsql_UTF-8.sql) which should have been run automatically while installing mapbender.
Did you use the install.bat under resources\db\install.bat? It should have created some logfiles in the same dir (log_update.txt, err_update.txt...), please take a look for
errormessages concerning the mentioned columns.
I would like to solve this issue for future users...


Am 26.07.2012 09:33, schrieb Ramesh De Silva:
> Dear Thomas,
> Thanks for the directions.  By referring to the log file; I found that "mod_loadwms.php" is referring to a non existing column (uuid) in the relation "wms". So I just
> added a new column in the relation "wms" in postgres level. Then; when I tried to load the WMS; again I got a similar issue for another relation (this time relation
> "layer"). I did the same workaround. After that I was able to load the WMS without any errors. 
> I wonder whether it requires to address this issue in "pgsql_schema_2.5.sql".
> Thanks again.
> Cheers
> Ramesh
> On Thu, Jul 26, 2012 at 1:59 PM, Thomas Baschetti <info at thomas-baschetti.de <mailto:info at thomas-baschetti.de>> wrote:
>     Hi,
>     do you see any errors in your logfiles (php and postgresql)? Perhaps you have to activate logging to see something there.
>     Which MS4W-Version are you using?
>     Thomas
>     Am 26.07.2012 05:29, schrieb Ramesh De Silva:
>>     Hi,
>>     When I try to Load a new WMS ( which is running in the same machine) using the "Load WMS" option provided in admin interface; I come across the following error
>>     message. I use Mapbender version 2.7.3. 
>>     *file: http://***.***.***.192/cgi-bin/mapserv.exe?map=/ms4w/apps/srilanka/sl.map&REQUEST=GetCapabilities&SERVICE=WMS&VERSION=1.1.0sql error: ERROR: unnamed prepared
>>     statement does not exist ROLLBACK performed....*
>>     But if I try to load the same WMS temporary using the "Adding WMS" option in GUI Template Application; it works fine. Assuming it is a database error; I tried with
>>     different versions of PostgreSQL ( V 8.2 and 9.1.4); but the result was the same.
>>     Also if I use an older Mapbender version ( V 2.4) the WMS loads permanently without any error. 
>>     Please provide me any possible solution for this issue.
>>     Thank you.
>>     Cheers
>>     Ramesh
>>     _______________________________________________
>>     Mapbender_users mailing list
>>     Mapbender_users at lists.osgeo.org <mailto:Mapbender_users at lists.osgeo.org>
>>     http://lists.osgeo.org/mailman/listinfo/mapbender_users


Thomas Baschetti - Systemanalyse Geographische Informationssysteme
Hakenstraße 8D
49074 Osnabrück

Tel: 0541 25 91 90 | mobil 01577 189 25 91
E-Mail: info at thomas-baschetti.de
Ust-IdNr.: DE264355072

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/mapbender_users/attachments/20120726/d7f182fe/attachment-0001.html>

More information about the Mapbender_users mailing list