[Mapbender-users] Connection error with geometry server, internal error 500

Patrick Meis Meis at stadt-muenster.de
Mon May 2 02:15:09 PDT 2016

Hello everybody,

as I'm still having trouble to get a connection to my search_db too, I just tried to start Mapbender 3 with app_dev, as
Astrid suggested, to read the errors.
Now I discovered that with app_dev my connection sems to be working, and I finally got results in my search router.

Whereas when I am starting Mapbender normally (without app_dev) the search router keeps on saying "no results"
and the prod.log says:

request.CRITICAL: Uncaught PHP Exception Symfony\Component\DepenencyInjection\Exception\ServiceNotFoundException:
"You have requested a non-existent service "doctrine.dbal.geo_osm_connection". Did you mean this: "doctrine.dbal.default.connection"?
at /var/www/mapbender3/app/bootstrap.php.cache line 2027

My database is not on localhost.
The configuration is as:

    # database-connection "default"
    database_driver:   pdo_sqlite
    database_host:     ~
    database_port:     ~
    database_name:     ~
    database_path:     %kernel.root_dir%/db/demo.sqlite
    database_user:     ~
    database_password: ~

    # database-connection "geo_osm"
    database2_driver:   pdo_pgsql
    database2_port:     5432
    database2_name:     geo_osm
    database2_path:     ~
    database2_user:     geo_osm
    database2_password: ********

Now the question is:
what is different when I try the search router request with app_dev???


Am 02.05.2016 09:09, schrieb astrid.emde at wheregroup.com:

Hi Zhandos,

please check the real name of your Database in PostgreSQL. Is it named seach_db as you wrote in parameter.yml (database2_name:     search_db)?

Are you allowed to access the database?
Clear the cache
Call Mapbender with app_dev.php to get the errors. Something like http://localhost/mapbender3/app_dev.php

The rest looks fine.

Best regards


Am 30.04.2016 09:09, schrieb zh.kerimkulov at gharysh.kz:
Hello Mapbender Users!!!

I tried to use Digitizer element, but faced connection error with geometry server.

Step by step:

1/ I changed config.yml file:

        default_connection: default
                driver:   %database_driver%
                host:     %database_host%
                port:     %database_port%
                dbname:   %database_name%
                path:     %database_path%
                user:     %database_user%
                password: %database_password%
                charset:  UTF8
                logging: %kernel.debug%
                profiling: %kernel.debug%
                driver:   %database2_driver%
                host:     %database2_host%
                port:     %database2_port%
                dbname:   %database2_name%
                path:     %database2_path%
                user:     %database2_user%
                password: %database2_password%
                charset:  UTF8
                logging: %kernel.debug%
                profiling: %kernel.debug%

2/ and parameters.yml file.

    # database-connection "default"
    database_driver:   pdo_pgsql
    database_host:     localhost
    database_port:     5432
    database_name:     mapbender3
    database_path:     ~
    database_user:     postgres
    database_password: postgres

    # database-connection "search_db"
    database2_driver:   pdo_pgsql
    database2_host:     localhost
    database2_port:     5432
    database2_name:     search_db
    database2_path:     ~
    database2_user:     postgres
    database2_password: postgres

3/ then I tried to create DB by console utility like this: app/console doctrine:database:create
But this utility create only default DB, search_db did not created by script. I create it manually and added extension Postgis. After that I added tables with SQL query for tables table public.poi, public.polygons, public.lines, then I added Digitizer element to the side panel of application and put YAML-Definition to the textarea schemes but it did not solve the problem, I still have  "Connection error with geometry server, internal error 500".

Thank you,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/mapbender_users/attachments/20160502/5dc608cf/attachment-0001.html>

More information about the Mapbender_users mailing list