[mapguide-users] Copying resources from MapGuide Enterprise to MapGuide OS

sc80 sc1980GIS at googlemail.com
Wed Jan 13 08:54:35 EST 2010

Thanks Kenneth.

I installed Maestro 2.0 beta 1 but I kept on getting this error:


So I performed the GetResourceContent and found upon returning to Maestro I
tried to open the layer again and it worked! I immediately tried to open
other layers (without performing a GetResourceContent) and they too worked.
Indeed everything's working now, so i'm happy even if i'm confused as to
what the issue would have been. I've included the xml from the
GetResourceContent in case that sheds any light on it for you.

Thanks again for your help.


<?xml version="1.0" encoding="UTF-8" ?> 
- <LayerDefinition xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:noNamespaceSchemaLocation="LayerDefinition-1.3.0.xsd" version="1.3.0">
- <VectorLayerDefinition>
- <PropertyMapping>
- <PropertyMapping>
- <PropertyMapping>
- <PropertyMapping>
- <PropertyMapping>
- <PropertyMapping>
- <VectorScaleRange>
- <LineTypeStyle>
- <LineRule>
  <LegendLabel /> 
- <LineSymbolization2D>


Kenneth Skovhede, GEOGRAF A/S wrote:
> The data files in the "Repositories/Library" folder is a dbxml database, 
> and not intended for
> reading or writing by anything but MapGuide (eg. don't modify it with a 
> text editor).
> The document it refers to the layer, which is an xml document (stored in 
> the dbxml).
> The numbers are indeed (linenumber, columnnumber), but in the 
> LayerDefinition xml document.
> I think the problem is caused by using an older version of Maestro which 
> does not recognize
> LayerDefinition version 1.3.0 (which Studio creates).
> If you use Maestro 2.0 beta 1, it should open the resource just fine.
> If not, you can get the actual resource xml by visiting the html test
> form:
> http://localhost/mapguide/mapagent/index.html
> Use the GetResourceContent operation to get the xml, and respond with a
> mail linking to the xml, and I will see if I can find obvious errors.
> Regards, Kenneth Skovhede, GEOGRAF A/S
> On 13-01-2010 11:48, sc80 wrote:
>> Hi all,
>> We have been using the trial version of MapGuide Enterprise 2010 however
>> we
>> are now looking to use MapGuide OS v2.1 and would like to utilise the
>> resources we created with Enterprise. From reading about resources I
>> thought
>> it would just be a case of copying the contents of the library folder
>> (Repositories\Library) for Enterprise to the equivalent location in the
>> OS
>> version. When i did this however (having re-created the appropriate
>> aliases
>> for the data connections) although the data connections work and i am
>> able
>> to preview the features in Maestro (v1.0.9.15910) the layer resources
>> seem
>> to have been corrupted as when i try to open them in Maestro I get an
>> error:
>> Unable to open the resource
>> Library://FolderName/Layers/SubFolder/layername.LayerDefinition
>> Error Message: There is an error in xml document (2,117)
>> I've looked into the MgLibraryResourceContents.dbxml but I can't see
>> anything obviously wrong (although i am very new to mapguide and have
>> little
>> development knowledge). Would this even be the xml document to which it's
>> referring? and is the (2,117) referring to a row and character position
>> in
>> this document?
>> Has anyone got any suggestions as to what is causing this or how I might
>> be
>> able to try to resolve this?
>> I've googled the error, but it was to no avail and the MapGuide Studio
>> 2010
>> Getting started guide is of little help.
>> Any help gratefully received.
>> Thanks in advance.
>> Sam
> _______________________________________________
> mapguide-users mailing list
> mapguide-users at lists.osgeo.org
> http://lists.osgeo.org/mailman/listinfo/mapguide-users

View this message in context: http://n2.nabble.com/Copying-resources-from-MapGuide-Enterprise-to-MapGuide-OS-tp4341045p4348669.html
Sent from the MapGuide Users mailing list archive at Nabble.com.

More information about the mapguide-users mailing list