[mapguide-users] Initial map extent problem

Jacqueline W jackiejwoodruff at gmail.com
Tue Dec 2 07:03:45 PST 2014

This is some additional information about the issue with initial map extents
jumping around as the map is loaded in the fusion viewer. These are fusion
applications that have been upgraded from mapguide 2.4 to mapguide 2.6 and
are being authored by maestro 5.1.

If we turn off the Maps layer entirely the atlases are really quite fast.
However, when google maps are selected as basemaps, when the atlas is first
loading we see a flash of an extent that wraps the entire globe into the
viewport a couple of times, then it jumps to a point feature like
"Albert's", then it jumps to the extent of the data from the Mapguide

Perhaps the viewer is making and cancelling Google Maps API calls prior to
receiving the extents back from Mapguide, which is causing all the jumping
around? We have tried passing a set of initial map extents in the layout
definition while ensuring the map definition has an extent representing the
entire data set. We have tried passing the initial map extents in the URL
for the fusion application as well.

View this message in context: http://osgeo-org.1560.x6.nabble.com/Initial-map-extent-problem-tp5175318p5176015.html
Sent from the MapGuide Users mailing list archive at Nabble.com.

More information about the mapguide-users mailing list