[mapserver-dev] missing files using built-in OpenLayers template

Jeff McKenna jmckenna at gatewaygeomatics.com
Mon Jun 16 05:58:43 PDT 2014

Hi THomas,

Yes in fact I placed those files there this morning, the 'img' and
'theme' folders were missing.

Correct, this single file build does not seem to be properly looking for
those files, it should be looking right in the same folder.


On 2014-06-16, 9:55 AM, thomas bonfort wrote:
> Jeff,
> The files are present now (c.f.
> http://www.mapserver.org/lib/theme/default/) however there's something
> wrong with our generated javascript as it's requesting the theme files
> from http://server/cgi-bin/theme/default/style.css instead of
> www.mapserver.org/lib/...
> On 16 June 2014 14:27, Jeff McKenna <jmckenna at gatewaygeomatics.com> wrote:
>> Still no luck, I would have thought that this OpenLayers single build
>> would look in the same directory for the img and theme folders.  Anyone
>> have any ideas?
>> -jeff
>> On 2014-06-16, 9:09 AM, Jeff McKenna wrote:
>>> Oh ok great, thanks for confirming this Lars, I thought I was going crazy :)
>>> I have no idea how the website and github are linked now, but I just
>>> poked around the ProjectsVM and found that js file, so I copied the img
>>> and theme folders there: http://www.mapserver.org/lib/  ...but still no
>>> luck.  Will keep looking.
>>> -jeff
>>> On 2014-06-16, 5:47 AM, Schylberg Lars wrote:
>>>> You are right Jeff,
>>>> The openlayers script was missing in April and I asked that it would be put back.
>>>> It was recoverd but unfortunally the small images was not put back.
>>>> I started to use a local copy at the same time so I forgot to mention that as well.
>>>> /Lars S.
>>>> -----Original Message-----
>>>> From: mapserver-dev-bounces at lists.osgeo.org [mailto:mapserver-dev-bounces at lists.osgeo.org] On Behalf Of Jeff McKenna
>>>> Sent: den 16 juni 2014 00:32
>>>> To: 'MapServer Dev Mailing List'
>>>> Subject: [mapserver-dev] missing files using built-in OpenLayers template
>>>> Hello all,
>>>> I have hit a wall, and I am hoping someone can confirm my suspicions.
>>>> When using the built-in OpenLayers template (http://mapserver.org/development/rfc/ms-rfc-63.html), I believe there are some missing "img" and "theme" folders on the server where the OpenLayers-ms60.js file lives: http://mapserver.org/lib/
>>>> If I test the CGI with MODE=browse&TEMPLATE=openlayers, my map will always appear, I can zoom/pan, but the OpenLayers control images (zoom,
>>>> pan) are broken.  Firebug is looking for them at something like and
>>>> Looking at http://mapserver.org/lib/ I see that the OL file was modified on April 15th...I wonder if this has to do with the server changes, and possibly those img/style folders were not moved?
>>>> Or put another way: can anyone else see the zoom/pan images now when trying mode=browse&template=openlayers ??
>>>> Thanks all!
>>>> -jeff
>>>> PS. it would be odd if I am the first person to notice this in 2 months!!!
>>>> _______________________________________________
>> _______________________________________________
>> mapserver-dev mailing list
>> mapserver-dev at lists.osgeo.org
>> http://lists.osgeo.org/mailman/listinfo/mapserver-dev

Jeff McKenna
MapServer Consulting and Training Services

More information about the mapserver-dev mailing list