[Mapserver-users] Configure: Same old error - can't find gd.h or libgd.a/libgd.so

Norman Vine nhv at cape.com
Wed May 26 15:21:48 EDT 2004

Adam Quiney writes:
> Hi All,
> I've looked through the archives and the FAQ and tried the solutions 
> presented, but to no avail.
> I am trying to install Mapserver 4.0.2 on Cygwin (running under Windows 
> 2000).
> Please let me know if there is anything else I should be trying to do - I'm 
> running out of hair to tear out of my head.
> Here is the output from configure.sh when run:
> ... Everything running fine above here ...
> checking for strcasecmp... yes
> checking for strncasecmp... yes
> checking for strdup... yes
> configure: checking whether we should include JPEG support......
> checking for jpeg_read_header in -ljpeg... no
>         libjpeg not found. JPEG support not included, possibly needed for 
> GD.
> configure: checking where FreeType 2.x is installed......
>         using libfreetype from -lfreetype -lz
> checking for FT_Init_FreeType in -lfreetype... no
>         using libfreetype -lfreetype -lz from system libs.
> configure: checking where Zlib is installed......
>         using libz from -L/lib -lz
> configure: checking where PNG is installed......
> checking for png_init_io in -lpng... no
>         PNG (libpng) library cannot be found, possibly needed for GD
> configure: checking where libXpm is installed......
> checking for XpmFreeXpmImage in -lXpm... no
>         XPM (libXpm) library cannot be found, possibly needed for GD
> configure: checking where libiconv is installed......
> checking for libiconv_open in -liconv... no
>         libiconv library cannot be found, possibly needed for GD
> configure: checking for GD 2.0.12 or higher......
> checking for gdImageSetAntiAliased in -lgd... no
> configure: error: "Could not find gd.h or libgd.a/libgd.so in /usr/local/.  
> Make
> sure GD 2.0.12 or higher is compiled before calling configure."
> I have tried running "./configure --with-gd=/usr/local", as well as with 
> /usr/local/lib (the location of the libgd.a file) and /usr/local/include 
> (the location of the gd.h file).
> I have looked through for duplicates of these files, but cannot find any 
> others residing on the disk.

Have you actually installed the libraries that are being reported as missing ? 
These are not installed in the 'default' Cygwin install and non default packages
need to be explicitly requested in the Cygwin setup program.

Also note that if you want GDAL or Proj4 support you will have to compile 
them yourself.  If you have problems when compiling either best to ask for help 
on the repsective maili list

Although I use a Cygwin compiled mapserver I have to ask are you sure
that you wouldn't find it easier using the native Win32 version for which
a binary package is available for download.




More information about the mapserver-users mailing list