[osgeo4w-dev] Re: [FWTools] gdal_polygonize.py bindings error

Cristiano Giovando giovand at gmail.com
Thu Feb 5 03:54:22 EST 2009

> Frank Warmerdam-2 wrote:
>> jjknoops at netscape.net wrote:
>>> Hello Everybody,
>>> I was trying to use gdal_polygonize.py but i get an error that i am
>>> using an old 'gen'.
>>> But the strange thing is that i can run the script with out any variable
>>> without any problem.
>> ...
>>> I am using FWTools228 on a windows XP computer. The python version I am
>>> using is the one supplied with fwtools (2.3.4)
>>> What I am i doing wrong?
>> Jaap,
>> gdal_polygonize is not supported on FWTools because FWTools uses the old
>> gen bindings.  This doesn't cause a problem in the "usage message" part of
>> the script - only in the call to gdal.Polygonize() itself.
>> You can use OSGeo4W's "gdal-dev" package if you want to try out the
>> polygonize
>> function.


I tried gdal_polygonize.py in OSGeo4W's gdal-dev (both current and
experimental) but it returns the same error message.

gdal.Polygonize() not available.  You are likely using "old gen"
bindings or an older version of the next gen bindings.

Any hint?



More information about the osgeo4w-dev mailing list