[postgis-users] info (solved)

Chris Hermansen chris.hermansen at timberline.ca
Fri Jun 6 08:34:13 PDT 2008

That's pretty interesting.

I have good old fashioned plain Ubuntu 8.0.4 and there's no proj stuff
in /usr/local/lib.

You can ask dpkg to tell you where a file comes from, eg:

$ dpkg -S /usr/include/math.h
libc6-dev: /usr/include/math.h

Chris H wrote:
> On Friday 06 June 2008 10:12:04 Chris Hermansen wrote:
> The problem was that "a" package, unknown at this time which one, dumped proj 
> libs into /usr/lib and /usr/local/lib. Removing that libs from /usr/local/lib 
> and running ldconfig as root did the trick. I have a commit on Kubuntu 8.0.4
> To track this down as to why and what the source of the dual lib entry I will 
> have to do another day but my first guess would be an unclean postgresql 
> build system by the packager. Not sure so don't want to point fingers. Its 
> just a starting point. 
> Regardless it all works now, so I am pleased. Can move on to the next issue 
> now. 
> Thanks for all the input. Its appreciated.  


Chris Hermansen         mailto:chris.hermansen at timberline.ca
tel+1.604.714.2878 · fax+1.604.733.0631 · mob+1.778.232.0644
Timberline Natural Resource Group · http://www.timberline.ca
401 · 958 West 8th Avenue  · Vancouver BC · Canada · V5Z 1E5

More information about the postgis-users mailing list