[postgis-users] troubles installing PostGIS

Mark Cave-Ayland mark.cave-ayland at siriusit.co.uk
Sun Feb 22 23:40:37 PST 2009

Geoffrey Fairchild wrote:

> I'm installing a clean install of PostgreSQL 8.3.6 on Vista 64 
> Ultimate.  I'm using the stack builder to install PostGIS 1.3.5.  
> PostgreSQL installs just fine. When I use the stack builder to install 
> PostGIS, it downloads just fine, but when I go to install I get this 
> error message: http://i44.tinypic.com/2eojgd0.png (I also attached this 
> screenshot to this email.)  I've tried turning off UAC, giving myself 
> full read/write/modify privaleges for that directory, logging into the 
> Administrator account, and nothing works.  I just get that error every 
> time.  The file it's referencing exists.  PostgreSQL is functioning 
> perfectly (I've created tables, inserted data, etc).  I tried clicking 
> ignore, and the installer continues and appears to succeed, but that 
> error is worrysome.  I just want to make sure I'm not going to have a 
> buggy install.  Does anyone have any idea why this happening?  Thanks!
> Geoff

Hi Geoff,

I'm afraid I don't have access to Vista in order to find out what is 
happening - all of the development for the current Win32 installer is 
done under Win32.

There have been some reports of various permissions errors coming up on 
the list, but so far I haven't been able to find out enough information 
in order to determine what is going wrong. Does the NSIS installer log 
(appears at the end of the wizard) provide any useful information at all?



Mark Cave-Ayland - Senior Technical Architect
PostgreSQL - PostGIS
Sirius Corporation plc - control through freedom
t: +44 870 608 0063

More information about the postgis-users mailing list